rust-doc package broken ubuntu

Asked by Ricardo Grant on 2018-03-26

As you are most likely aware the rust-doc package is broken on Ubuntu 16.04 lts, I am wondering if this will be fixed any time soon? Otherwise I would love to help solve this problem since the status is currently unassigned.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu rustc Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-03-26
Last query:
2018-03-26
Last reply:
2018-03-26

I suggest you report a bug.

Ricardo Grant (granttrec) said : #2

There already is a bug report, the status is unassigned.
On Mon, Mar 26, 2018 at 04:10, actionparsnip wrote:
Your question #667227 on rustc in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227 (https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227)

Status: Open => Answered

actionparsnip proposed the following answer:
I suggest you report a bug.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227/+confirm?answer_id=0 (https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227/+confirm?answer_id=0)

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227 (https://answers.launchpad.net/ubuntu/+source/rustc/+question/667227)

You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #3

How do you define "the package is broken" - not installable, or crashing on use, or ...?
And if it is only the -doc package. can you use the real application without documentation?

Which bug are you referring to?
Details please!

Ricardo Grant (granttrec) said : #4

My apologies. The package is not installable. See: https://bugs.launchpad.net/ubuntu/+source/rustc/+bug/1721425
Yes, the application still works without the doc.

Best Manfred Hampl (m-hampl) said : #5

I assume that the dependency on fonts-open-sans can be fulfilled by downloading and manually installing
http://launchpadlibrarian.net/318129592/fonts-open-sans_1.11-1_all.deb
or by adding a ppa that provides this package.

Ricardo Grant (granttrec) said : #6

Thanks Manfred Hampl, that solved my question.