Should ruby1.8 be default ruby for Ubuntu Precise?

Asked by Neil Wilson on 2012-02-21

ruby1.8 is the default ruby for precise at the moment. 1.8.7 is supposed to drop out of support by the middle of 2013, and security updates are not going to happen.

Is there a way that ruby could be transitioned to 1.9 during the maintenance period?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ruby-defaults Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-21
Last reply:
2012-02-21

I don't think. Search here for the package:
http://packages.ubuntu.com/

Like you can see, Ruby is at the version 1.8:
http://packages.ubuntu.com/search?keywords=ruby&searchon=names&suite=precise&section=all

I suggest you to report this as bug. And specify in the comment that the 1.8 version will be out dated in 2013.

Can you help with this problem?

Provide an answer of your own, or ask Neil Wilson for more information if necessary.

To post a message you must log in.