ruby1.9 for precise

Asked by vlagorsse

As everybody knows, ruby1.9.X is out since 2010. It has come with new exciting features, more performances (30% on my subjectives benches). When it has been out, ruby1.9 was having some regressions. A lot has been fixed and i use ruby1.9 is very usable at daily time.

Why is 1.8 still beign version planned for precise ?

1. Official support will stopped by June 2013: How can precise will deal with that. (source:
2. Today, we find more and more ruby1.9 only compatible projects. Gitlab is one of these. Maintain double compatibility is hard and painful for developpers.
3. Developpment of 2.0 has started: the situation will get more complicated if precise remains on 1.8.7

Don't you think precise is the rigth time to move on ?


Question information

English Edit question
Ubuntu ruby-defaults Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

andy@fileserver:~$ apt-cache show ruby1.9.3
Package: ruby1.9.3
Priority: optional
Section: universe/ruby
Installed-Size: 186
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: akira yamada <email address hidden>
Architecture: all
Source: ruby1.9.1
Depends: ruby1.9.1 (>=
Recommends: ruby1.9.1-full (>=
Filename: pool/universe/r/ruby1.9.1/ruby1.9.3_1.9.3.0-1ubuntu1_all.deb
Size: 13488
MD5sum: 3f34396a7e85f4a25c85858874425a23
SHA1: a66b32d0d62c4468aeeb1a400629d44b14c823c4
SHA256: 5f05f72462d3fcc5a575c7211ed4ce24e0d8d42da1dd09bc7edee64402180755
Description-en: Interpreter of object-oriented scripting language Ruby, version 1.9.3
 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 Ruby uses two parallel versioning schemes: the `Ruby library compatibility
 version' (1.9.1 for this package), which is similar to a library SONAME, and
 the `Ruby version' (1.9.3 for this package). Ruby packages in Debian are
 named using the Ruby library compatibility version, which is sometimes
 confusing for users who do not follow Ruby development closely. This package
 depends on the ruby1.9.1 package, and provides compatibility symbolic links
 from 1.9.3 executables and manual pages to their 1.9.1 counterparts.
Description-md5: aa611a7522ee6c493d69294af0dd1d4b
Origin: Ubuntu

andy@fileserver:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

andy@fileserver:~$ uname -a
Linux fileserver 3.2.0-7-generic #13-Ubuntu SMP Sat Dec 24 18:06:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
vlagorsse (vincent-lagorsse) said :

Thank you for your response. I think i don't have asked my question correctly.

Why is it ruby1.8 that is installed when we install ruby package ? Can't 1.9 be the default version ? On this url ( it seems that for precise, it also will be ruby1.8 by default.

Is it still appropriate to package ruby1.8 by default in precise knowing that:
1. ruby1.8 will be no longer supported after june 2013
2. more and more software with 1.9 as prerequisite
3. development team call to move to 1.9 and have begin to develop 2.0

Thanks !

Revision history for this message
actionparsnip (andrew-woodhead666) said :

There are a lot of ruby1.9 packages available in Precise.

ruby1.9.1 - Interpreter of object-oriented scripting language Ruby
ruby1.9.1-dev - Header files for compiling extension modules for the Ruby 1.9.1
ruby1.9.1-examples - Examples for Ruby 1.9
ruby1.9.1-full - Ruby 1.9.1 full installation
ruby1.9.3 - Interpreter of object-oriented scripting language Ruby, version 1.9.3

If this isn't what you mean I suggest you report a bug and it should get updated

Revision history for this message
Khairul Aizat Kamarudzzaman (fenris) said :

how about ruby 1.9.2 ?

Revision history for this message
Jeremy Wilkins (jeb-jdwilkins) said :

The packages are for Ruby 1.9.3 (despite the 1.9.1 naming)

The issue is that development of Ruby 1.8.x has already stopped, but that is the default version shipping in the latest LTS release of Ubuntu.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug to alert the devs that 1.8.x is dead (possible citations etc to back it up)

Can you help with this problem?

Provide an answer of your own, or ask vlagorsse for more information if necessary.

To post a message you must log in.