How to enable https/ssl for rtpg

Asked by davidm

I don't see any option to force rtpg into https/ssl mode. I set it up under a 443 server, but all the frame pages try to load on port 80.


Question information

English Edit question
Ubuntu rtpg Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jacobsallan (jacobsallan) said :

Try placing a hello.html or hello.php application in the same directory and work through the Apache configuration. I'll bet there is a mistake in your Apache server setup.

If you need further assistance, describe how you configured Apache to restrict access to https for this site.

Revision history for this message
davidm (vid) said :

https://site/index.cgi works fine. But rtpg is adding <base href="http://site/"/> to each each generated page. <base href="https://site/"/> is what I want, but there's no configuration parameter for that in the documentation. Since it's a high level Perl toolkit, there must be a central configuration for this. I could track it down, but it should be in the example documentation.

Revision history for this message
Jacobsallan (jacobsallan) said :

There is a module, but there are no settings for https.

I think this is not an accident. RTPG is a user interface for rTorrent client. BitTorrent is a peer to peer transport protocol, so you get pieces of files from many different hosts and the selection of hosts is not deterministic. SSH does not make sense in an environment like this as it would require all BitTorrent clients everywhere to hold a key from the host you are downloading from.

Revision history for this message
davidm (vid) said :

One would want to use rtpg under https so one's collection of files is not revealed casually to the world. On a multi user host, for example, many people could be downloading torrents, an individual's collection would be protected just as they would be in many other applications of encryption. rtpg is designed to run under a web server, which should manage the protocol, it's unnecessary and unusual to use a base href. I think you're just making excuses for a missing basic feature.

Can you help with this problem?

Provide an answer of your own, or ask davidm for more information if necessary.

To post a message you must log in.