Cannot open '/run/rpcbind/portmap.xdr' file for reading

Asked by Gaetano Gambilonghi on 2012-01-20

I've updated my kernel, and now i have 3 errors, 2 in my startup screen:
Jan 20 17:55:13 asus904 rpcbind: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)
Jan 20 17:55:13 asus904 rpcbind: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)

and then something i didn't like on my close-screen:
rpc.statd[1014]: Caught signal 15, un-registering and exiting
kernel: [ 309.279667] init: statd main process (1014) terminated with status 1
rpcbind: rpcbind terminating on signal. Restart with "rpcbind -w"
kernel: [ 311.339523] init: portmap main process (807) terminated with status 2
statd-pre-start: started
kernel: [ 340.052669] init: statd pre-start process (3501) terminated with status 2

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu rpcbind Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-20
Last reply:
2013-06-05

Hi Gaetano Gambilonghi,

I think you can safely ignore those erros. If you don't use any service that depends on rcpbind (like nfs for example) you can get rid of those rcpbind errors by removing rcpbind from your system

    apt-get remove --purge rpcbind

HTH

--
hmontoliu <at> ubuntu.com
http://hmontoliu.blogspot.com

Indie (alanlitster) said : #2

I have exactly the same problem with a fresh install+update of Oneiric

Linux release 3.0.0-16-server #29-Ubuntu SMP Tue Feb 14 13:08:12 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I use NIS/autofs/NFS.

On startup I get the following

rpcbind: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)
rpcbind: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)

Manually stopping the service with "stop portmap" causes it to write those files and then starting it again cause it to work fine as they already exist.

With the server is shutdown it goes down really fast so I don't think the rpcbind process has enough time to write the files to the directory. rpcbind is started by default with the -w option

     -w Cause rpcbind to do a "warm start" by read a state file when rpcbind starts up. The state file is created when
             rpcbind terminates.

Indie (alanlitster) said : #3

It's fixed upstream in rpcbind_0.2.0-7 but really rpcbind shouldn't whinge about it.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620800

--- portmap.conf.orig 2011-07-19 05:15:12.000000000 +0100
+++ portmap.conf 2012-03-09 11:15:07.997246728 +0000
@@ -30,5 +30,7 @@
  elif [ -f /etc/rpcbind.conf ]; then
   . /etc/rpcbind.conf
  fi
+ [ -f /run/rpcbind/rpcbind.xdr ] || touch /run/rpcbind/rpcbind.xdr
+ [ -f /run/rpcbind/portmap.xdr ] || touch /run/rpcbind/portmap.xdr
  exec rpcbind $OPTIONS
 end script

Indie (alanlitster) said : #4

It's fixed upstream in rpcbind_0.2.0-7 but really rpcbind shouldn't whinge about it.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620800

--- portmap.conf.orig 2011-07-19 05:15:12.000000000 +0100
+++ portmap.conf 2012-03-09 11:15:07.997246728 +0000
@@ -30,5 +30,7 @@
  elif [ -f /etc/rpcbind.conf ]; then
   . /etc/rpcbind.conf
  fi
+ [ -f /run/rpcbind/rpcbind.xdr ] || touch /run/rpcbind/rpcbind.xdr
+ [ -f /run/rpcbind/portmap.xdr ] || touch /run/rpcbind/portmap.xdr
  exec rpcbind $OPTIONS
 end script

David Robert Lewis (afrodeity) said : #5

any release downstream?

Steve Langasek (vorlon) said : #6

The patch you propose here is absolutely incorrect and must not be used. It will cause upstart to fail to track the rpcbind process.

Steve Langasek (vorlon) said : #7

The patch you propose here is absolutely incorrect and must not be used. It will cause upstart to fail to track the rpcbind process.

martin suc (martin-suc) said : #8

any release ?

Kai Bojens (0-kb-p) said : #9

I am using NIS/NFS and I still have these errors showing up:

rpcbind: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)

Semen Stepanov (k14412) said : #10

I am try to use NFS for my diskless PC and PXE (https://help.ubuntu.com/community/DisklessUbuntuHowto).
Use 12.04 i386.
And I have same problem. NFS do not work.
Is there any chance that it will work on Ubuntu?

Sorry for my bad English.

Sergey Pashinin (pashinin) said : #11

I use NFS and have this error, and periodically my PC can't boot because of NFS mounting.
How can it be fixed??????

Stephen Combs (stphn-combs) said : #12

Perhaps, it may have something to do with a malformed "interfaces" document (usually found in "/etc/network/interfaces"). Sometimes, if there is a call to brctl that fails, the line referring to brctl needs to be commented out. There seems to be a link between the rpcbind resources and brctl . Without fully knowing the issue, I can only give you what I've faced in the past.

Stephen Combs (stphn-combs) said : #13

--more --

To test a theory, I tried putting any bad lines into the interfaces document and came up with the same results. So, it's not necessarily the brctl, as I thought, but a malformed interfaces doc, in general, that caused the issue.

EvilSupahFly (seann-giffin) said : #14

My /etc/network/interfaces looks like this:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

And that seems fine to me, for a simple setup in a fixed location with only one NIC. I'm on Ringtail, use NFS Server, and I'm getting "Cannot open '/run/rpcbind/portmap.xdr' file for reading" and "Cannot open '/run/rpcbind/rpcbind.xdr' file for reading" errors on startup. What's happening with this?

Can you help with this problem?

Provide an answer of your own, or ask Gaetano Gambilonghi for more information if necessary.

To post a message you must log in.