iPod nano doesn't free up memory

Asked by mwolfer1 on 2007-05-30

When I delete ('move to trash') titles from my iPod nano via Rhythmbox the space is not freed up on the iPod ('about' still shows 0 MB free). Works ok when done via iTunes on a WindoZe PC. Any suggestions? Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Solved by:
mwolfer1
Solved:
Last query:
Last reply:
Caleb (caleb-marcus) said : #1

This actually moves it to a trash folder on the iPod, and you can empty that as well as your computer's trash by right-clicking on the Trash icon in the taskbar and clicking Empty Trash.

mwolfer1 (mwolfer1) said : #2

I hate to disagree, but that's not what is happening. The trash folder remains empty and cannot be emptied.

What happens if you then unmount the ipod from the icon on the desktop? Do the changes you have requested then get "written"? (the deletions)

mwolfer1 (mwolfer1) said : #4

Nope, the trash container remains empty. Just for kicks I tested the same thing with my 60 GB iPod: same behaviour (I just didn't notice so far since there was space left).

No, I am not suggesting you empty the trash, just right click the device and choose unmount. Sometimes write operations get queued up until you unmount the device.

mwolfer1 (mwolfer1) said : #6

I did that anyway (who would just yank the iPod out ;-), the message that write operations were happening appeared, after a few seconds the ready to remove message appeared.

Bryan Haskins (bryan-h) said : #7

This happens on a lot of plug and g odevices, try mounting it normally and viewing hidden files (ctrl+h in gnome) go to .Trash if it is there, and manually highlight and delete those, they will really be deleted now.

mwolfer1 (mwolfer1) said : #8

Nope, sounded good but still no cigar. I don't see any hidden files when I open the device for instance using nautilus. I start to suspect more and more that this might be another 64bit issue. I tested banshee which appears to be using the same access mechanism that rhythmbox is using and find the same problem. I installed gtkpod and that seems to do the trick, I assume because it handles interaction with the iPod directly. Unfortunately gtkpod is the least user friendly of the three. Thanks for your help anyway.

Cesare Tirabassi (norsetto) said : #9

Apparently it is still an open issue (being fixed....):

http://bugzilla.gnome.org/show_bug.cgi?id=346434

Best mwolfer1 (mwolfer1) said : #10

Thanks, my bad, I didn't check bugzilla before asking.

bob (moneet007) said : #11

how do i free up space on my ipod- see the prblem is that i tried downloading a movie and it would not show (that does not matter) but its not working on my ipod so i deleted the movie but its still using the memory space up what do i do

placidoaps (placidoaps) said : #12

I have the same issue, and for more sophisticated tasks I use gtkpod.
to clear ophan files do:

file - Check iPod's Files
or
 just look for the files - select and right click and delete them

I hope this issue can be fixed soon!

scumbag (scumbag82) said : #13

I just got a second hand 2GB ipod nano and deleted all the songs on it using Rhythmbox. I then tried using banshee to put my music onto it and the memory appeared to be full despite there being no songs on the ipod. Had a bit of a fiddle and eventually freed some space up using gtkpod as suggested... however it has only freed up 208mb!!! when I try to delete the rest of the ipod's contents using the 'check ipod functions' I keep getting the warning:

File "/media/COMPAQ_OWNE/iPod_Control/Music/F00/04 - Carry On.mp3" has zero play length. Ignoring.

The following track could not be processed (filetype is known but analysis failed): '/media/COMPAQ_OWNE/iPod_Control/Music/F00/04 - Carry On.mp3'

File "/media/COMPAQ_OWNE/iPod_Control/Music/F12/08 - Headless - Heartless.mp3" has zero play length. Ignoring.

The following track could not be processed (filetype is known but analysis failed): '/media/COMPAQ_OWNE/iPod_Control/Music/F12/08 - Headless - Heartless.mp3'

File "/media/COMPAQ_OWNE/iPod_Control/Music/F18/05 - Automation.mp3" has zero play length. Ignoring.

The following track could not be processed (filetype is known but analysis failed): '/media/COMPAQ_OWNE/iPod_Control/Music/F18/05 – Automation.mp3'

Can anyone help? or have I just got a very nice ipod shaped paperweight???