Song won't play

Asked by Smee

It was working fine yesterday, but today every time I try to play a song (.flac) it stays at 0:00. The play button is highlighted and everything, and I don't get any errors. I've tried playing it by double clicking the song, by hitting the button, and doing Control -> Play. I also tried restarting it. Help please

Question information

English Edit question
Ubuntu rhythmbox Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Deepak Mishra (dpux) said :

is this problem limited to any single player, and a single format ??

Revision history for this message
Smee (downwithx) said :

When you say a single player do you mean rhythmbox? Because that's the only music player this is happening in.
This time i opened up Rhythmbox to check if it would play any .ogg files (.ogg and .flac are the only kind I have) and instead of just not playing it it would seem to realize it couldn't play it and skip to the next. So it kept going down through the list, not playing .flacs or .oggs.

Revision history for this message
Trygve Vea (trygve-vea-gmail) said :

If you start the application from the console, does it give any output when playback fails? Error messages or so?

When you right click a song, push properties and details -> Does it exist on the Location specified? (Remember that case is relevant in linux)

If you don't mind attempting to rebuild your music library, you can exit any instances you might have running of Rhythmbox, and rename the ~/.gnome2/rhythmbox directory. Then you start with a clean rhythmbox-configuration.

I hope this helps :)

Regards, Trygve

Revision history for this message
Smee (downwithx) said :

Well today I opened up rhythmbox and it's working perfectly. I still don't know what was the problem, but I'm going to mark it as solved. Thanks for the help you guys!