new install, os sees soundcard and has driver, no sound

Asked by paul m on 2008-07-05

Binary package hint: rhythmbox

ubuntu 8.04, soundblaster audigy.

ProblemType: Bug
Architecture: i386
Date: Fri Jul 4 21:05:55 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.5-0ubuntu8
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-19-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-05
Last reply:
2008-07-05
paul m (paul-skrovan) said : #1
Sebastien Bacher (seb128) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at [WWW] https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see [WWW] https://help.ubuntu.com/community/ReportingBugs .

Thinboy00 (thinboy00) said : #3

Does this problem apply outside of rhythmbox?

paul m (paul-skrovan) said : #4

yes, i essentially have no sound, though the apps (rhythmbox and the dvd player) seem to work fine (i.e. they launch automatically, see the media, and play it, but nothing is heard).

Audio trouble with Ubuntu 8.04 some common checks

-- If you are using a laptop, your laptop may have a keyboard function to manipulate your sound.
   Check that. Your laptop may have a keyboard control to mute, increase and decrease sound.
-- Please check your sound devices volumes are to a high level double click on the top right loudspeaker icon you will see a mixer
-- Please make common test from menu System->Preferences->Sounds
   if you are using PulseAudio please read: http://www.pulseaudio.org/wiki/PerfectSetup or try if using ALSA things go better
-- If you have two audio cards - please disable the on board audio card using BIOS setting, please check with this terminal command:

   lspci | grep -i audio

-- Please be sure your pc are starting with the generic kernel press ESC at boot when you see the GRUB row then select the "kernel.... - generic" row
-- Please be sure all needed kernel modules are installed to make this check and install them:
  So open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-ubuntu-modules-$(uname -r)

give your user password when requested, you don't see nothing when you type it, then press enter.

Then reboot your pc.

-- Be sure your user is member of audio group
Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo adduser $(who am i | cut -d" " -f 1) audio
sudo chmod 660 /dev/snd/*

give your user password when requested, you don't see nothing when you type it, then press enter.

-- Please try to watch what audio cards are detected on your system please type:
asoundconf list

if more than one sound cards is detected by your system to set the default soundcard

asoundconf set-default-card PARAMETER

change PARAMETER with the name of a one detected sound card

-- Please try to delete making a backup copy of this conf files
mv .asoundrc .asoundrc_old
mv .asoundrc.asoundconf .asoundrc.asoundconf.old
sudo mv /etc/asound.conf /etc/asound.conf.old

Please take a look at this http://ubuntuforums.org/showthread.php?t=205449

-- Please try to discover if there are any process they are keeping the /dev/dsp locked
ps -edalf | grep -i dsp

kill them using this command:

kill -9 number_of_pid

---------

If you microphone seems don't record your voice please open a terminal and type

alsamixer

and press tab to switch in view to [Capture] section, and then pressing space on mic and mic boost aid

If you are using Pulseaudio and you have some sound issue with sound apps please read http://www.pulseaudio.org/wiki/PerfectSetup
and this http://ubuntuforums.org/showthread.php?p=4928900

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask paul m for more information if necessary.

To post a message you must log in.