Rhythmbox cannot play music files

Asked by Bernard Drapeau on 2008-02-27

Binary package hint: rhythmbox

I'm trying to play music files.
The program's interface is ubdates accordingly but there is no "music activity". the ruler is not moving, there is no music

ProblemType: Bug
Architecture: i386
Date: Wed Feb 27 13:55:20 2008
DistroRelease: Ubuntu 8.04
Package: rhythmbox 0.11.4-0ubuntu6
PackageArchitecture: i386
SourcePackage: rhythmbox
Uname: Linux 2.6.24-8-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Solved by:
Bernard Drapeau
Solved:
2008-03-13
Last query:
2008-03-13
Last reply:
2008-03-13
Pedro Villavicencio (pedro) said : #2

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Johannes Pilkahn (j-pilkahn) said : #3

Can you please post the output of "cat /proc/asound/cards"? Thank you.

Further, do you have the "ubuntu-restricted-extras" package installed? If not,open a terminal and type: "sudo apt-get install ubuntu-restricted-extras"

Fred Allnutt (dotandfred) said : #4

  I have just installed Ubuntu 6.06 and am having trouble with virtually everything. Rhythm box downloaded from a cd fine but it wont play the music although it says its playing but no sound. when I tried to play direct from the the Cd it says it cannot connect with the sound drivers. what do I do?

@Fred Allnut

Rythmbox "is playing but there is no sound".

I solved this problem in Hardy 8.04 alpha 3 i386 by specifying the ALSA driver. The could be a problem with hardware autodetection on your computer.

(Hardy is the only system working on my box. I cannot help you for Ubuntu 6.06.)

In Hardy alpha 6 i386, I left the settings to autodectetion and it works properly

In the menu you go to System / Preferences / Sound. Then change "Sound Events" to ALSA, and "Music and Movies" to ALSA

I m using ubuntu 7.10 in my dell laptop INSPIRON 1525 however i m not able to play any mp3 files in it. It give an error that GStreamer not found, Neither i m able to install it from add/remove, terminal, synaptic package manager

Ben J Woodcroft (donttrustben) said : #7

I had the same problem, and managed to workaround by specifying ALSA al la @Bernard Drapeau

$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xefffc000 irq 19

I have ubuntu-restricted-extras installed, but was also having exactly the same problem before I did so.

Ben J Woodcroft (donttrustben) said : #8

Sorry I'm on Hardy, and I never had a problem such as this in gutsy.

praet (praet17) said : #9

wwood, have you tried what Bernard Drapeau posted above?
After upgrading to Hardy I had this issue and used the same steps to correct it. ( you can use the test buttons to verify that the audio setting you are using is correct)

Todd Ogin (ojintoad) said : #10

This worked for me, however, this is a user workaround that shouldn't be necessary, right? I mean, why isn't it autodetecting an output source that can work? If that is a different bug it should be reported. Can someone help me in reporting this new bug?

I just ripped a few cd's on my hardy heron hard drive, and when I go to play the .m4a's, it get a message saying "Playback Error Failed to connect stream: Invalid argument" I've no idea what to do about this.