autostart rhythmbox

Asked by zasq on 2007-12-16

Hi there!
I want rhythmbox to start to play an audio-cd automatically when I put it in the drive. I already changed the commandline for the device and rhythmbox is opened when I put in an audio-cd. But it won't start to play the disc by itself... Is there any option I am missing?
Thank you!
Zasq

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Please try to play from system->Preferences->Removable drives and media-> with
Storage and Multimedia (tabs)

Hope this help

zasq (zasq) said : #2

Thanks Marcobra! That's exactly what I did. I put in the command "rhythmbox". The program does open, but the music won't start automatically. So I wonder whether there is an option "rhythmbox -option xy" that I am missing...

From menu Applications->Accessories->Terminal try to view the start parameter of rhythmbox-client command, type:

man rhythmbox-client

Hope this help

If your commando is already working you would just have to add at the final of your command "& rhythmbox-client --play" To play just after rhythmbox open.

vishnoo (piotr-lesnicki) said : #5

Hi,
did you manage to solve your problem ? I don't see a clean answer...

I did manage to do it but in a very dissatisfying way by putting the following command in my "Removable drives and media" :

rhythmbox-client && sleep 2 && rhythmbox-client --clear-queue && rhythmbox-client --play-uri="cdda://1#%d"

The "sleep 2" is required, as the "play-uri" action does not seem buffered and is ommitted otherwise!
The "clear-queue" action is also required otherwise it plays only the first track and then plays the queue.

Anyone has a better solution ?

Max (maximimilienarturo) said : #6

I find another way to disable autostart.

In Nautilus (file navigator) > Edit > Preferences > Last tab 'Support' (in french)

Then choose what you want for each device

It works for me

For french readers :

Lancer Nautilus (navigateur de fichier) > Edition > Préférences > Support (dernier onglet)

Choississez chaque action pour chaque support

zasq (zasq) said : #7

Hi everybody!
Thanks for all your suggestions but unfortunately, none of them worked for me, not mattering whether I made changes in Nautilus or in the Configuration Editor. So, I'll still have to press the play button after inserting an audio-cd...l
Sorry...

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

zasq (zasq) said : #9

Hi again,
sorry, but this still doesn't work. I installed intrepid now, but the problem remains. If I doubleclick on a mp3 or ogg file in nautilus (or whereever), rhythmbox opens without playing the music. If I go back to Nautilus and doubleclick again, then the music will start. Now, if rhythmbox is already open and I doubleclick on a piece, rhythmbox will start to play the first piece in my music archive and not the one I wished to hear.
Should I file this as a bug?
Tx

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.