How to play musich which is not in your library?

Asked by obstriegel

Rhythmbox is a horrible player, but it could be so great I think. I would use VLC but Rhythmbox seems to be integrated so well in the ubuntu-desktop, that I thought others would probably use it too, so it should "just work".
However I can't get basic playback to work in that player.
I just want to play a single mp3 file, which is not in my music library so I drag it to the playlist of Rhythmbox. The program says "Importing ..." for half an hour now, but never completes and never plays my file. This happens only with some files. All other players I tried have no problems with it (VLC, Listen, Exaile, Totem...). The other players have other issues why I do not want to use them.

Update: I deleted my library and now I see that the file is actually added to the library so I can play it. But the "Importing (0/1)" does only go away when the application is restarted, which confused me at first. So there is no way of playing a file without first adding it to the library of Rhythmbox and then clicking it or dragging it to a playlist?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu rhythmbox Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
ajmal_82 (ajmal-82) said :
#1

i would suggest u make simple change that in open with menu and start using banshee or exaile iam comfortable with exaile but Rhythmbox allows you to edit mp3 tags thats hellalot good feature as per me but if you only want to play then exaile and banshee or good choice

Revision history for this message
arochester (arochester) said :
#2

Have you installed?: ubuntu-restricted-extras

It is a meta-package and installs a bunch of useful stuff including MP3 playback...

Revision history for this message
obstriegel (obstriegel) said :
#3

Yes, playback works. I was just confused by the status bar saying it is still importing it and also tried to drag files to a playlist which seems not possible.

Revision history for this message
obstriegel (obstriegel) said :
#4

I found a bug report which describes the odd user experience and will continue to post there. They say it's fixed, but does not work for me with symbolic links to songs. https://bugzilla.gnome.org/show_bug.cgi?id=592546

Can you help with this problem?

Provide an answer of your own, or ask obstriegel for more information if necessary.

To post a message you must log in.