Ubuntu

restricted-manager won't start!

Asked by Iliya Ilembitov on 2007-10-15

Today I've installed Gutsy Gibbon Release candidate from CD and downloaded all the updates. After that, the restricted manager won't start! An attempt to start it from terminal would result in:
jheronimus@jheronimus-laptop:~$ sudo restricted-manager
Traceback (most recent call last):
  File "/usr/bin/restricted-manager", line 42, in <module>
    rm = RestrictedManager()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 53, in __init__
    RestrictedManagerCommon.__init__(self,args,opts)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerCommon.py", line 197, in __init__
    self.launch_manager()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 151, in launch_manager
    self.ManagerWindow(self.xml, self.handlers, self)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 209, in __init__
    self.reset_model()
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 262, in reset_model
    self.parent.set_title_label(self.xml.get_widget('label_heading'), any_enabled)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerGtk.py", line 122, in set_title_label
    (bold, normal) = RestrictedManagerCommon.title_label(self, in_use)
  File "/usr/lib/python2.5/site-packages/RestrictedManager/RestrictedManagerCommon.py", line 242, in title_label
    'these drivers.') % {'os': get_os_name()}
KeyError: u's'

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu restricted-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Iliya Ilembitov
Solved:
2007-10-16
Last query:
2007-10-16
Last reply:
2007-10-16

This question was reopened

Jon Ramvi (ramvi) said : #1

You may be missing some updates

Run this (again):
sudo apt-get update
sudo apt-get dist-upgrade

Did that help?

Well, I've tried that like 3,5 hours ago. Was any update for restricted manager released? I've only seen an update for ubuntu-desktop and so on, nothing more - and nothing changes.

Err... Strange - the problem stays here as solved and i got a confirmation - but I didn't report that it's solved! Is it normal?

Okay, I've reopened. The problem still stays, although all updates are applied.

vitja (vitja-makarov) said : #5

This problem exists in ru_RU.utf-8 locale launching it as "LC_ALL=C restricted-manager" works ok.