epmd can't connect between two node in ipv6

Asked by shen.zhixing on 2018-04-14

I have two vm, they are deployed IPV6, ping6 success between them, but "rabbitmqctl join_cluster" failed . I found "net_adm:ping" was fail.

so I stopped rabbitmq-server.service , I stop iptables.service, setenforce 0, and check like below,

I can't find out why they did not connect,anybody know ?

[root@ctrl-2 system]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
10:1:1::10 ctrl-2
10:1:1::11 ctrl-1
10:1:1::15 ctrl-3

[root@ctrl-3 system]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 ip6-loopback
10:1:1::10 ctrl-2
10:1:1::11 ctrl-1
10:1:1::15 ctrl-3
=====================================================================
[root@ctrl-3 system]# ping6 10:1:1::10
PING 10:1:1::10(10:1:1::10) 56 data bytes
64 bytes from 10:1:1::10: icmp_seq=1 ttl=64 time=0.118 ms
64 bytes from 10:1:1::10: icmp_seq=2 ttl=64 time=0.100 ms

[root@ctrl-3 system]# ping6 ctrl-2
PING ctrl-2(ctrl-2) 56 data bytes
64 bytes from ctrl-2: icmp_seq=1 ttl=64 time=0.086 ms
64 bytes from ctrl-2: icmp_seq=2 ttl=64 time=0.132 ms

=====================================================================
[root@ctrl-3 system]# epmd -address 10:1:1::15 -port 4369 -daemon
[root@ctrl-3 system]# netstat -anp|grep 4369
tcp 0 0 127.0.0.1:4369 0.0.0.0:* LISTEN 20742/epmd
tcp6 0 0 10:1:1::15:4369 :::* LISTEN 20742/epmd
tcp6 0 0 ::1:4369 :::* LISTEN 20742/epmd

[root@ctrl-2 system]# epmd -address 10:1:1::10 -port 4369 -daemon
[root@ctrl-2 system]# netstat -anp|grep 4369
tcp 0 0 127.0.0.1:4369 0.0.0.0:* LISTEN 3176/epmd
tcp6 0 0 10:1:1::10:4369 :::* LISTEN 3176/epmd
tcp6 0 0 ::1:4369 :::* LISTEN 3176/epmd

=====================================================================

[root@ctrl-2 system]# erl -sname a
Erlang/OTP 18 [erts-7.3.1] [source] [64-bit] [smp:16:16] [async-threads:10] [hipe] [kernel-poll:false]

Eshell V7.3.1 (abort with ^G)
(a@ctrl-2)1> auth:set_cookie('abcdefg').
true
(a@ctrl-2)2>
(a@ctrl-2)2>
(a@ctrl-2)2> net_adm:ping('b@ctrl-3').
pang
(a@ctrl-2)3>
(a@ctrl-2)3>
(a@ctrl-2)3> net_adm:ping('b@ctrl-3').
pang
(a@ctrl-2)4> net_adm:ping('a@ctrl-2').
pong
----------------
[root@ctrl-3 system]# erl -sname b
Erlang/OTP 18 [erts-7.3.1] [source] [64-bit] [smp:16:16] [async-threads:10] [hipe] [kernel-poll:false]

Eshell V7.3.1 (abort with ^G)
(b@ctrl-3)1> auth:set_cookie('abcdefg').
true
(b@ctrl-3)2>
(b@ctrl-3)2>
(b@ctrl-3)2>
(b@ctrl-3)2> net_adm:ping('b@ctrl-3').
pong
(b@ctrl-3)3> a

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu rabbitmq-server Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-14
Last reply:
2018-04-30
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

shen.zhixing (fooy5460) said : #2

It was solved by set env "-proto_dist inet6_tcp" in rabbitmq-env.config.