perl dependency in qtbase5-dev-tools 5.5.1+dfsg-16ubuntu7.2

Asked by James Carter on 2017-05-18

Hello,

I am setting up a cross compilation environment with the host being Xenial 16.04 amd64 and targeting Xenial 16.04 armhf.

I require the qtbase5-dev-tools:armhf package. Installing it causes a dependency conflict concerning perl:armhf and perl:amd64.

For now I simply download the package, remove the perl dependency and install.

I was wondering if this is safe, considered a bad practice, or if there is a better solution to the problem.

Thanks,
James

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qtbase-opensource-src Edit question
Assignee:
No assignee Edit question
Last query:
2017-05-18
Last reply:
2017-05-26
Manfred Hampl (m-hampl) said : #1

What is the error message that you get concerning perl:armhf and perl:amd64?

I suggest that you create a bug report to get this to the attention of the developers - or maybe it is the issue already reported as Bug #1574351 then you could click the "affects me too" button.

James Carter (jacarterjr) said : #2

It looks like the bug you mentioned was only part of the problem. After applying the fix the system still gives errors.
It seems as if it doesn't detect that the dependencies for the perl:armhf package have been satisfied. Here's the errors
for the sake of completeness.

$ sudo apt-get install perl:armhf
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 perl:armhf : Depends: perl-base:armhf (= 5.22.1-9) but it is not going to be installed
              Recommends: rename:armhf but it is not installable
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install perl-base:armhf
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libuuid1:armhf : Depends: passwd:armhf
                  Recommends: uuid-runtime:armhf
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

$ dpkg -l | grep passwd
ii base-passwd 3.5.39 amd64 Debian base system master password and group files
ii passwd:armhf 1:4.2-3.1ubuntu5 armhf change and administer password and group data

$ dpkg -l | grep libuuid1
ii libuuid1:amd64 2.27.1-6ubuntu3 amd64 Universally Unique ID library
ii libuuid1:armhf 2.27.1-6ubuntu3 armhf Universally Unique ID library

Manfred Hampl (m-hampl) said : #3

What is the output of the commands

sudo dpkg --audit
sudo apt-get install --no-install-recommends perl:armhf perl-base:armhf

James Carter (jacarterjr) said : #4

$ dpkg --audit
<no output>

$ sudo dpkg --audit
[sudo] password for <username>:
<no output>

$ sudo apt-get install --no-install-recommends
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gcc-4.8-base:armhf icu-devtools libasan0:armhf libasan2:armhf libatomic1:armhf libboost-atomic1.58-dev:armhf libboost-atomic1.58.0:armhf libboost-chrono1.58-dev:armhf libboost-chrono1.58.0:armhf
  libboost-context1.58-dev:armhf libboost-context1.58.0:armhf libboost-coroutine1.58-dev:armhf libboost-coroutine1.58.0:armhf libboost-date-time1.58-dev:armhf libboost-date-time1.58.0:armhf
  libboost-exception1.58-dev:armhf libboost-filesystem1.58-dev:armhf libboost-graph-parallel1.58-dev:armhf libboost-graph-parallel1.58.0:armhf libboost-graph1.58-dev:armhf libboost-graph1.58.0:armhf
  libboost-iostreams1.58-dev:armhf libboost-iostreams1.58.0:armhf libboost-locale1.58-dev:armhf libboost-locale1.58.0:armhf libboost-log1.58-dev:armhf libboost-log1.58.0:armhf libboost-math1.58-dev:armhf
  libboost-math1.58.0:armhf libboost-mpi-python1.58-dev:armhf libboost-mpi-python1.58.0:armhf libboost-mpi1.58-dev:armhf libboost-mpi1.58.0:armhf libboost-program-options1.58-dev:armhf
  libboost-program-options1.58.0:armhf libboost-python1.58.0:armhf libboost-random1.58-dev:armhf libboost-random1.58.0:armhf libboost-regex1.58-dev:armhf libboost-regex1.58.0:armhf
  libboost-serialization1.58-dev:armhf libboost-serialization1.58.0:armhf libboost-signals1.58-dev:armhf libboost-signals1.58.0:armhf libboost-system1.58-dev:armhf libboost-test1.58-dev:armhf
  libboost-test1.58.0:armhf libboost-thread1.58-dev:armhf libboost-thread1.58.0:armhf libboost-timer1.58-dev:armhf libboost-timer1.58.0:armhf libboost-wave1.58-dev:armhf libboost-wave1.58.0:armhf
  libboost1.58-dev:armhf libboost1.58-tools-dev libexpat1-dev:armhf libgcc-4.8-dev:armhf libgcc-5-dev:armhf libgomp1:armhf libhwloc-dev:armhf libhwloc-plugins:armhf libhwloc5:armhf libibverbs-dev:armhf
  libibverbs1:armhf libicu-dev:armhf libltdl-dev:armhf libltdl7:armhf libopenmpi-dev:armhf libopenmpi1.10:armhf libpciaccess0:armhf libpcre16-3 libpython-dev:armhf libpython2.7:armhf libpython2.7-dev:armhf
  libqt5core5a libqt5dbus5 libqt5xml5 libstdc++-4.8-dev:armhf libstdc++-5-dev:armhf libubsan0:armhf mpi-default-bin:armhf mpi-default-dev:armhf ocl-icd-libopencl1:armhf openmpi-bin:armhf openmpi-common
  qttranslations5-l10n rename
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Manfred Hampl (m-hampl) said : #5

This was not the command tat I asked for. Please try again with

sudo apt-get install --no-install-recommends perl:armhf perl-base:armhf

James Carter (jacarterjr) said : #6

Sorry about that. Here is the requested commands' output.

$ sudo apt-get install --no-install-recommends perl:armhf perl-base:armhf
[sudo] password for jcarter:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libuuid1:armhf : Depends: passwd:armhf
 perl:armhf : Depends: perl-modules-5.22:armhf (>= 5.22.1-9)
              Depends: libperl5.22:armhf (= 5.22.1-9) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Manfred Hampl (m-hampl) said : #7

Ok, and what do you get for the command

sudo apt-get install --no-install-recommends perl:armhf perl-base:armhf libperl5.22:armhf

(I assume "trying to overwrite shared '/usr/share/doc/libperl5.22/changelog.Debian.gz'..." which is as Bug #1574351 )

Can you help with this problem?

Provide an answer of your own, or ask James Carter for more information if necessary.

To post a message you must log in.