Qt 5.4

Asked by Brendan Klare on 2015-06-29

Hello. I am curious why this package is for Qt 5.2 and not current Qt 5.4 version? Thank you.

Update:

My distro version is:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu qtbase-opensource-src Edit question
Assignee:
No assignee Edit question
Solved by:
Brendan Klare
Solved:
2015-06-30
Last query:
2015-06-30
Last reply:
2015-06-30

What is the output of:

lsb_release -a; uname -a

Thanks

Brendan Klare (bklare) said : #2

Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty

Thanks.

You are using the LTS release. Unless there is a significant reason to upgrade the version (huge security / bug fixes) the version will remain the same.

There may be a PPA with the version you desire but these will be compiled by Dave Somebody out on the web.

If you want newer packages then you will need to use the latest release, even if it isn't LTS. If you can wait until April next year, 16.04 will be released and you can upgrade to that in one jump (LTS to LTS upgrades are supported and recommended).

Brendan Klare (bklare) said : #4

I had not thought of some of the requirements for ensuring LTS and this all makes perfect sense. Thank you very much for the clarification, the support of this package, and the timely response!