need Qt 4.4.x

Asked by Roland Hughes on 2008-09-27

I'm trying to help the KDE Konsole maintainer with getting the DEC VT terminal support actually working given that I have an OpenVMS machine to test it against and am very familiar with the platform. The latest svn requires qt4.4.x to build. When will a package be released?

-- Configuring done
-- Generating done
-- Build files have been written to: /home/roland/kde/src/kde/kdelibs
CMake Error at cmake/modules/FindQt4.cmake:1483 (MESSAGE):
  The installed Qt version 4.3.4 is too old, at least version 4.4.0 is
  required
Call Stack (most recent call first):
  cmake/modules/FindKDE4Internal.cmake:281 (find_package)
  CMakeLists.txt:33 (find_package)

Thanks,
Roland

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-28
Last reply:
2009-10-17
Shriramana Sharma (jamadagni) said : #1

Hello. You need to be more informative about what version of Ubuntu you are running. If you are running Hardy, then you have Ubuntu's Qt packages version 4.4.0-1ubuntu5~hardy1 available from the hardy-backports repository. If you are running Intrepid Alpha, you won't have this question.

If you have an older version than Hardy, you may need to backport Qt 4.4.0 to your older version yourself, but that may not be a trivial task. Seeing as Hardy is a Long-Term-Support release (meaning you get security updates for 18 months for this release) I would advise you to upgrade to Hardy.

Roland Hughes (yyyc186) said : #2

64-bit AMD LTS.

I know what packages I have, the question was WHEN will 4.6.x be
released.

On Sat, 2008-09-27 at 15:27 +0000, Shriramana Sharma wrote:

> Your question #46488 on qt4-x11 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/qt4-x11/+question/46488
>
> Status: Open => Answered
>
> Shriramana Sharma proposed the following answer:
> Hello. You need to be more informative about what version of Ubuntu you
> are running. If you are running Hardy, then you have Ubuntu's Qt
> packages version 4.4.0-1ubuntu5~hardy1 available from the hardy-
> backports repository. If you are running Intrepid Alpha, you won't have
> this question.
>
> If you have an older version than Hardy, you may need to backport Qt
> 4.4.0 to your older version yourself, but that may not be a trivial
> task. Seeing as Hardy is a Long-Term-Support release (meaning you get
> security updates for 18 months for this release) I would advise you to
> upgrade to Hardy.
>

Gord Allott (gordallott) said : #3

ubuntus packages generally arn't upgraded once a final ubuntu version is released, you have to wait for the next version of ubuntu before the packages are updated to newer versions

for example in ubuntu hardy (LTS) libqt4 is at 4.3.4 but in ubuntu intrepid (which will be released in october) the version is at 4.4.2.
thus if you want a newer version of an application or library you have to wait for the next version of ubuntu

Roland Hughes (yyyc186) said : #4

I need 4.6 to help this guy. Are you telling me I have to install Suse?

On Sat, 2008-09-27 at 19:38 +0000, Gord Allott wrote:

> Your question #46488 on qt4-x11 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/qt4-x11/+question/46488
>
> Status: Open => Answered
>
> Gord Allott proposed the following answer:
> ubuntus packages generally arn't upgraded once a final ubuntu version is
> released, you have to wait for the next version of ubuntu before the
> packages are updated to newer versions
>
> for example in ubuntu hardy (LTS) libqt4 is at 4.3.4 but in ubuntu intrepid (which will be released in october) the version is at 4.4.2.
> thus if you want a newer version of an application or library you have to wait for the next version of ubuntu
>

Gord Allott (gordallott) said : #5

if you want to use a newer version of some software you will either have to compile it yourself or wait until the next version of ubuntu which is released next month. you can try using the alpha version of the next version of ubuntu but you do so at your own risk (its called alpha for a reason)

the alpha version is here: http://www.ubuntu.com/testing/intrepid/alpha6

Shriramana Sharma (jamadagni) said : #6

> I know what packages I have, the question was WHEN will 4.6.x be released.
> I need 4.6 to help this guy. Are you telling me I have to install Suse?

Hello. As far as I know, Trolltech (Nokia) has not released even Qt 4.5, so where are you going to get Qt 4.6? And anyway, your answer as to what version of Ubuntu you are using is incomplete:

> 64-bit AMD LTS.

Is it Dapper LTS or Hardy LTS? If it is Hardy, my previous answer stands. If it is Dapper, again it stands.

Roland Hughes (yyyc186) said : #7

Your previous answer had nothing to do with the question.

64-bit AMD Hardy LTS.

4.6.x is currently being used by ALL KDE maintainers and is required to
build any of the KDELIBS SVN packages on the trunk.

On Sun, 2008-09-28 at 05:04 +0000, Shriramana Sharma wrote:

> Your question #46488 on qt4-x11 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/qt4-x11/+question/46488
>
> Shriramana Sharma proposed the following answer:
> > I know what packages I have, the question was WHEN will 4.6.x be released.
> > I need 4.6 to help this guy. Are you telling me I have to install Suse?
>
> Hello. As far as I know, Trolltech (Nokia) has not released even Qt 4.5,
> so where are you going to get Qt 4.6? And anyway, your answer as to what
> version of Ubuntu you are using is incomplete:
>
> > 64-bit AMD LTS.
>
> Is it Dapper LTS or Hardy LTS? If it is Hardy, my previous answer
> stands. If it is Dapper, again it stands.
>

Roland Hughes (yyyc186) said : #8

>From your answer I gather that Ubuntu currently stands, and probably
will remain standing a full year behind all other distros.

On Sat, 2008-09-27 at 23:56 +0000, Gord Allott wrote:

> Your question #46488 on qt4-x11 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/qt4-x11/+question/46488
>
> Status: Open => Answered
>
> Gord Allott proposed the following answer:
> if you want to use a newer version of some software you will either have
> to compile it yourself or wait until the next version of ubuntu which is
> released next month. you can try using the alpha version of the next
> version of ubuntu but you do so at your own risk (its called alpha for a
> reason)
>
> the alpha version is here: http://www.ubuntu.com/testing/intrepid/alpha6
>

Gord Allott (gordallott) said : #9

ubuntu is not about having the most uptodate software 100% of the time, its about having a good desktop environment. if you want access to the most up todate software 100% of the time then you will have to either compile your software yourself or live 'on the bleeding edge' of a distro like gentoo.

just to note ubuntu is normally 6 months out of date as a new version is released every six months.

Roland Hughes (yyyc186) said : #10

Version 4.6.x of Qt is being used by the KDE team for development right
now and has been for some time. Your release in October will still be
behind that by at least eight months. I wouldn't care, but I want to
help the Konsole maintainer get the VT terminal support working
correctly. Now I'm going to have to install SuSe on another machine
just to do that.

On Sun, 2008-09-28 at 17:11 +0000, Gord Allott wrote:

> Your question #46488 on qt4-x11 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/qt4-x11/+question/46488
>
> Status: Open => Answered
>
> Gord Allott proposed the following answer:
> ubuntu is not about having the most uptodate software 100% of the time,
> its about having a good desktop environment. if you want access to the
> most up todate software 100% of the time then you will have to either
> compile your software yourself or live 'on the bleeding edge' of a
> distro like gentoo.
>
> just to note ubuntu is normally 6 months out of date as a new version is
> released every six months.
>

Andy Ruddock (andy-ruddock) said : #11

Qt 4.4.3 is the latest available from the Qt ftp server. According to distrowatch opensuse has 4.4.2
I'm not sure what the svn verison the Qt devs are working on is, but I'll be surprised if it's up to 4.6.

If you *need* 4.6 to help somebody then you must be working on bleeding-edge, pre-alpha, software and you're beyond whatever a current distribution is going to ship - you're going to be needing to compile from source.

KDE's code switched to Qt4.6 on the 10th of October

Can you help with this problem?

Provide an answer of your own, or ask Roland Hughes for more information if necessary.

To post a message you must log in.