After latest update Unity no longer works

Asked by Alen Masic on 2013-10-29

Couple hours ago Unity was working, and after I installed latest updates Unity doesn't load anymore. I noticed this only happen with my account, when I log in as guest everything is ok. Is there any fix for this.
Currently I'm using Gnome Shell until I find solution for Unity

Question information

English Edit question
Ubuntu qt4-x11 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

What is the output of :

sudo lshw -C display; uname -a; lsb_release -a


Alen Masic (alenn-masic) said : #2

       opis: VGA compatible controller
       proizvod: C61 [GeForce 6100 nForce 420]
       proizvođač: NVIDIA Corporation
       fizički id: d
       info o sabirnici: pci@0000:00:0d.0
       verzija: a2
       širina: 64 bits
       klok: 66MHz
       mogućnosti: pm msi vga_controller bus_master cap_list rom
       konfiguracija: driver=nvidia latency=0
       resursi: irq:22 memorija:fb000000-fbffffff memorija:e0000000-efffffff memorija:fc000000-fcffffff memorija:80000000-8001ffff
Linux alen-RR841AA-ABD-t3720-de 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 17:26:33 UTC 2013 i686 athlon i686 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

Ok so why did you not state your GPU or the fact that you are using Saucy in the initial question? Unity is a plugin for Compiz which needs 3D acceleration to run.

If you make a fresh Ubuntu user is the Unity shell / Compiz usable?

Alen Masic (alenn-masic) said : #4

I know Unity need 3D acceleration, my GPU is fully capable for 3D acceleration. After fresh install everything was perfectly fine, I just lost Unity after last update. And when I log in as guest I have normal Unity environment.

Alen Masic (alenn-masic) said : #5

I forgot to answer on your last question. When I create new user everything is ok with Unity, it seems only my account is damaged

ok, boot to your own account and press ALT+F2, can you run:

compiz --replace

Does it load ok. We now know the settings in your account are whack. Again, why did you not mention release and GPU?

Alen Masic (alenn-masic) said : #7

I tried that before but it's the same. I managed to activate window decorations and open gl because they were disabled, but I can't enable Unity plugin. Also tried unity --replace but it's still the same

I did not mention release and GPU because I didn't know I was supposed to do so

You could try renaming the compiz config folders in your users home dir then when you start Compiz you will get default vanilla settings.

Compiz is a joke imho.

Alen Masic (alenn-masic) said : #9

Thanks actionparsnip, that solved my question.

Alen Masic (alenn-masic) said : #10

Thank you