Problems with pbuilder (qt5 packaging) in Ubuntu 13.04

Asked by Alen Masic on 2013-07-10

I had no problems with packaging app using pbuilder in previous versions of Ubuntu, but starting from 12.04 I have problems which I can't solve.
I configured pbuilder using instructions from these videos: https://wiki.ubuntu.com/MOTU/Videos but I still get dependencies problems. This is full log, so can you help me, also if I forgot to mention some details please remind me.

http://pastebin.com/AU7jiz66

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2013-07-15
Last query:
2013-07-15
Last reply:
2013-07-15
Manfred Hampl (m-hampl) said : #1

I see some inconsistencies in your pbuilder log:

Depends: ... libqt5core5 (>= 5.0.2), ... libqt5printsupport5 (>= 5.0.2), libqt5widgets5 (>= 5.0.2)

In the question title you claim to be running Ubuntu 13.04, but libqt5* release 5.0.2 is delivered only with Ubuntu 13.10
https://launchpad.net/ubuntu/+source/qtbase-opensource-src
The Saucy Salamander (active development) 5.0.2+dfsg1-7ubuntu2
The Raring Ringtail (current stable release) 5.0.1+dfsg-0ubuntu4

So the version of your OS, the pbuilder package you are using, and the libgt5 packages do not fit together for whatever reason.

Please provide the output of

uname -a
lsb_release -a
apt-cache policy pbuilder libqt5core5 libqt5printsupport5 libqt5widgets5

Alen Masic (alenn-masic) said : #2

uname -a:

Linux alen-RR841AA-ABD-t3720-de 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:36:13 UTC 2013 i686 athlon i686 GNU/Linux

lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

apt-cache policy pbuilder libqt5core5 libqt5printsupport5 libqt5widgets5:

intsupport5 libqt5widgets5
pbuilder:
  Instalirano: 0.213ubuntu1
  Kandidat: 0.213ubuntu1
  Tablica verzije:
 *** 0.213ubuntu1 0
        500 http://ba.archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
libqt5core5:
  Instalirano: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Kandidat: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Tablica verzije:
 *** 5.0.2+dfsg1-3ubuntu1~raring1~test2 0
        500 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-proper/ubuntu/ raring/main i386 Packages
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
     5.0.1+dfsg-0ubuntu4 0
        500 http://ba.archive.ubuntu.com/ubuntu/ raring/main i386 Packages
libqt5printsupport5:
  Instalirano: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Kandidat: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Tablica verzije:
 *** 5.0.2+dfsg1-3ubuntu1~raring1~test2 0
        500 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-proper/ubuntu/ raring/main i386 Packages
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
     5.0.1+dfsg-0ubuntu4 0
        500 http://ba.archive.ubuntu.com/ubuntu/ raring/main i386 Packages
libqt5widgets5:
  Instalirano: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Kandidat: 5.0.2+dfsg1-3ubuntu1~raring1~test2
  Tablica verzije:
 *** 5.0.2+dfsg1-3ubuntu1~raring1~test2 0
        500 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-proper/ubuntu/ raring/main i386 Packages
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
     5.0.1+dfsg-0ubuntu4 0
        500 http://ba.archive.ubuntu.com/ubuntu/ raring/main i386 Packages

Manfred Hampl (m-hampl) said : #3

As you can see, the package versions for libqt5* delivered with standard Ubuntu are 5.0.1...
You have installed 5.0.2... versions from two PPAs.

What is the "depends" information for the software that you want to package? Is the >=5.0.2 dependency really required?

You have to be aware, that pbuilder usually uses just the standard repositories, and can only find the 5.0.1 versions.

If your software depends on 5.0.2, the pbuilder scripts will probably fail, unless you configure your pbuilder environment that it also has the related PPAs enabled. This would have as consequence, that the users have also to enable these PPAs if they want to install your software.

Alen Masic (alenn-masic) said : #4

Well, part of problem is solved, now it seems qmake is missing

Can't exec "qmake": No such file or directory at /usr/share/perl5/Debian/Debhelper/Dh_Lib.pm line 215.
dh_auto_configure: qmake -makefile -nocache QMAKE_STRIP=: PREFIX=/usr failed to to execute: No such file or directory
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting dev/pts filesystem
I: unmounting proc filesystem
I: cleaning the build env
I: removing directory /var/cache/pbuilder/build//11464 and its subdirectories

What do I need to include in control file so system can find qmake.

Manfred Hampl (m-hampl) said : #5

Maybe adding qtchooser or qt4-qmake or qt5-qmake to build-depends makes qmake available to the pbuilder?

Alen Masic (alenn-masic) said : #6

I still have problems, now I got error which I never seen. Do you know what it means:

qmake: could not find a Qt installation of ''
dh_auto_configure: qmake -makefile -nocache QMAKE_STRIP=: PREFIX=/usr returned exit code 1
make: *** [build] Error 25
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting dev/pts filesystem
I: unmounting proc filesystem
I: cleaning the build env
I: removing directory /var/cache/pbuilder/build//4158 and its subdirectories

Manfred Hampl (m-hampl) said : #7

Sorry, this goes beyond my knowledge. I have no experience with qt5.

Which qmake has been used by pbuilder (of qt4 or qt5)?
Can you provide a few lines more of the build log, previous to the snippet you posted?

Alen Masic (alenn-masic) said : #8
Alen Masic (alenn-masic) said : #9

Is there someone else who knows solution for this problem

Best Manfred Hampl (m-hampl) said : #10

Just a bit guessing: You might need some more qt packages as build-depends, maybe qt5-default and/or qttools5-dev-tools

Alen Masic (alenn-masic) said : #11

Thank you, it's ok now

Alen Masic (alenn-masic) said : #12

Thanks Manfred Hampl, that solved my question.