installation of libqt4-gui fails with unmet dependencies

Asked by Stephan Fabel on 2012-07-31

~%sudo apt-get install libqt4-gui
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt4-gui : Depends: libqt4-designer (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.2 is to be installed
              Depends: libqt4-opengl (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.2 is to be installed
              Depends: libqt4-svg (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.2 is to be installed
              Depends: libqtgui4 (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.2 is to be installed
E: Unable to correct problems, you have held broken packages.

~%apt-cache policy libqt4-gui
libqt4-gui:
  Installed: (none)
  Candidate: 4:4.8.1-0ubuntu4
  Version table:
     4:4.8.1-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

~%apt-cache policy libqt4-designer
libqt4-designer:
  Installed: 4:4.8.1-0ubuntu4.2
  Candidate: 4:4.8.1-0ubuntu4.2
  Version table:
 *** 4:4.8.1-0ubuntu4.2 0
        100 /var/lib/dpkg/status
     4:4.8.1-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libqt4-gui (not installed)
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Mon Jul 30 16:13:41 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: qt4-x11
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qt4-x11 Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-31
Last reply:
2012-07-31
Jonathan Thomas (echidnaman) said : #1

It looks like you've partially upgraded Qt, but turned off the precise-updates repository. You can try fixing this by launching the Muon Software Center, going to Settings -> Configure Software Sources, going to the "Updates" tab, and ticking the "Recommended Updates" checkbox.

andy@fileserver:~$ apt-cache policy libqt4-designer
libqt4-designer:
  Installed: 4:4.8.1-0ubuntu4.2
  Candidate: 4:4.8.1-0ubuntu4.2
  Version table:
 *** 4:4.8.1-0ubuntu4.2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4:4.8.1-0ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

It's in the main repo, so will be installable, Jonathan seems to have this covered :)

gnc (gnc50) said : #3

Configure Software Sources, going to the "Updates" tab, and ticking the "Recommended Updates" checkbox. https://xender.pro/ https://discord.software/ https://omegle.onl/

Can you help with this problem?

Provide an answer of your own, or ask Stephan Fabel for more information if necessary.

To post a message you must log in.