How to install qemu-system-s390x on Ubuntu 16.04.4

Asked by Gael Crova on 2018-03-07

Hi,

I'm using an up to date Ubuntu Xenial 16.04.4 (x86_64) system but I can't see the qemu-system-s390x package.

Is package available for this Ubuntu version, or is there an issue with module packaging ?

Please note that I can see all other qemu-system modules (successfully using ppcle one).

Thanks for your help !
Regards
Gael

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu qemu Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-08
Last reply:
2018-03-08
Manfred Hampl (m-hampl) said : #1

If you look at https://packages.ubuntu.com/search?suite=all&arch=any&searchon=names&keywords=qemu-system-s390x you can see that qemu-system-s390x on Ubuntu 16.04 exists only for s390x architecture.

I do not know the reason for this, and for Ubuntu 17.10 and 18.04 it is provided for all standard architectures including amd64.

Gael Crova (gcrova) said : #2

Thanks Manfred !

Yes that's why I'm asking for any packaging issue on Xenial. Support for x86_64 would help me a lot !

Manfred Hampl (m-hampl) said : #3

There is bug #1710695 telling that this problem was solved for version 1:2.10 (delivered in Artful)

For xenial you should have a look at https://launchpad.net/~alindt/+archive/ubuntu/xenial-backports
Maybe that contains what you need.

Gael Crova (gcrova) said : #4

I can install the module using the backports repository but my "s390" Docker container is not working - so it might not be stable enough.
Do you know if there is an update planned for this package on Xenial in few days/weeks ?
Thanks again !

Manfred Hampl (m-hampl) said : #5

I do not expect that there is any change planned on xenial.
You can create a bug report, but I doubt that this will be done at all, because in a few weeks Ubuntu 18.04 LTS will be published, and as far as I can see it contains qemu-system-s390x for arm64 and i386.

Is it necessary that you run Ubuntu xenial (16.04)? Artful (17.10) and bionic (18.04) seem to have the package that you are looking for.

Gael Crova (gcrova) said : #6

Ok thanks ... I then have to wait for next LTS to be available as my infrastructure team is only providing us LTS Ubuntu machines.17.10 & 18.04 are not LTS yet.. so waiting.

Thanks !

Can you help with this problem?

Provide an answer of your own, or ask Gael Crova for more information if necessary.

To post a message you must log in.