qbittorrent not start after installing

Asked by Luis M.Jacinto on 2013-05-29

After been working faultless since January 2013 in Ubuntu 12.04 precise, open the application
from Dash on searching for another download I don’t know what I press qbittorrent disappear from the
screen and never could be restart again, with Synaptic I uninstall it restart Ubuntu and from
Synaptic i install qbittrorrent ver: 3.0x-4285-20130523-precise1.
But again can not start from Dash
The installation information after install:

Selecting previously unselected package qbittorrent.
(Reading database ... 587152 files and directories currently installed.)
Unpacking qbittorrent (from .../qbittorrent_3.0.x-0~4285-20130523~precise1_i386.deb) ...
Processing triggers for menu ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Setting up qbittorrent (3.0.x-0~4285-20130523~precise1) ...
Processing triggers for menu ...
W: Waited for dpkg --assert-multi-arch but it wasn't there - dpkgGo (10: No child processes)
 From Terminal get this results:

@-G41M-Combo:~$ qbittorrent
qbittorrent: error while loading shared libraries: libtorrent-rasterbar.so.6: cannot open shared object file: No such file or directory
@-G41M-Combo:~$

I like the application and wanting working again, please help to fix this problem.
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu qbittorrent Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-06-10
Last query:
2013-06-10
Last reply:
2013-05-30

What is the output of :

lsb_release -a; uname -a; apt-cache policy qbittorrent

Thanks

Luis M.Jacinto (ljacinto) said : #2

Thank you to answer hoping this will help.
@-G41M-Combo:~$ lsbrelease -a; uname -a; apt-cache policy qbittorrent
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
Linux luis-G41M-Combo 3.2.0-44-generic-pae #69-Ubuntu SMP Thu May 16 18:50:07 UTC 2013 i686 i686 i386 GNU/Linux
qbittorrent:
  Installed: 3.0.x-0~4285-20130523~precise1
  Candidate: 3.0.x-0~4285-20130523~precise1
  Version table:
 *** 3.0.x-0~4285-20130523~precise1 0
        500 http://ppa.launchpad.net/hydr0g3n/qbittorrent-stable/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     3.0.8-0ubuntu2~precise 0
        500 http://ppa.launchpad.net/hydr0g3n/ppa/ubuntu/ precise/main i386 Packages
     2.9.7-1 0
        500 http://za.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
@-G41M-Combo:~$

Then I suggest you report a bug to the PPA maintainer. I also suggest you remove the PPA you added, remove qbittorrent then reinstall so that you get the version from the official Ubuntu repos.

Luis M.Jacinto (ljacinto) said : #4

I remove installed qbittorrent from the system.
Don’t know the PPA maintainer to report the bug.
The download qbittorrent was from Synaptic (ver: 3.0x0-4285-20130523-precise1) this is the one in Ubuntu software centre and Synaptic, I thick the previous one was ver: 2.9.7 (not sure).
If reinstall it will end up the same version.
Searching for version from the official Ubuntu repos, found in askubuntu.com
I install trough Terminal but end up with

Fetched 1 883 kB in 19s (95,1 kB/s)
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
@-G41M-Combo:~$

During searching I found most downloads the same for hydr03n.
Is the http://ppa.lanchpad.net/hydr03n/qbittorrent-stable precise main the one you referring?

Please advise

Luis M.Jacinto (ljacinto) said : #5

After installing sudo add-apt-repository ppa:hydr0g3n/qbittorrent-stable gave error.
@-G41M-Combo:~$ qbittorrent
qbittorrent: error while loading shared libraries: libtorrent-rasterbar.so.6: cannot open shared object file: No such file or directory
Remove the rasterbar and reinstall qbittorrent fixed the problem.
Thank you for all the help.

Luis M.Jacinto (ljacinto) said : #6

Thanks actionparsnip, that solved my question.