Dependency on nvidia-current

Asked by Joachim Deguara on 2011-05-20

Why does python-pyopencl depend on nvidia-current? For my system with the AMD graphics cards and the proprietary fglrx driver installed, installing python-pyopencl and therefore nvidia-current make my system freeze when X is restarted.
What is needed from the nvidia-current package for python-pyopencl?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pyopencl Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-20
Last reply:
2011-05-20

Why are you installing both the ATi driver and the Nvidia driver? Very strange...

I don't actually want to install the Nvidia driver but I do want to install python-pyopencl. How python-pyopencl is current packaged it depends on the nvidia package and hence Ubuntu installs nvidia while I already have fglrx installed and that is why it freezes on X restart.

I suggest you log a bug

Can you help with this problem?

Provide an answer of your own, or ask Joachim Deguara for more information if necessary.

To post a message you must log in.