Set default PCI sound card in pulse audio

Asked by Peter Longhurst on 2009-11-20

Computer: Asus A8V m/board; AMD 64 4200 dual core CPU; 2gb RAM; 250gb HDD partitioned half and half between XP and ubuntu 8.04, which has recently been upgraded from 6.06. Pulse audio has been re-installed by following the processes set out in:
http://ubuntuforums.org/showthread.php?t=789578; and http://ubuntuforums.org/archive/index.php/t-1282745.html

Opening Pulse Audio Device Chooser from the top gives an error message: "Connection failed: Connection refused."

I have used $ asoundconf set-default-card - I typed asoundconf set-default-card M2496. The PCI card I want to set as default is an M-Audio 2496. Pulse audio needs "sink" and "source" to be set in order to work, if I understand correctly. Funny words to use?

Using $ pulseaudio & pavucontrol gives the following text in terminal:-

$ pulseaudio & pavucontrol
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
[1] 6249
W: alsa-util.c: Device front:1 doesn't support 44100 Hz, changed to 48000 Hz.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
W: alsa-util.c: Device front:1 doesn't support 44100 Hz, changed to 48000 Hz.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.ICE1712.pcm.surround71.0:CARD=0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround71:0
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 10.
W: alsa-util.c: Device hw:0 doesn't support sample format s16le, changed to s32le.
W: alsa-util.c: Cannot find fallback mixer control "PCM".
E: module-alsa-sink.c: Failed to create sink object
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_1412_1712_sound_card_0_alsa_playback_0"): initialization failed.
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.ICE1712.pcm.surround71.0:CARD=0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround71:0
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 12.
W: alsa-util.c: Device hw:0 doesn't support sample format s16le, changed to s32le.
W: alsa-util.c: Cannot find fallback mixer control "Mic".
E: module-alsa-source.c: Failed to create source object
E: module.c: Failed to load module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_1412_1712_sound_card_0_alsa_capture_0"): initialization failed.
E: module-alsa-sink.c: Failed to parse module arguments
E: module.c: Failed to load module "module-alsa-sink" (argument: "sink_name=M2496_out device=hw:M2496 format=s32le channels=10 channel_map=left,right,aux0,aux1,aux2,aux3,aux4,au x5,aux6,aux7"): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
[1]+ Exit 1 pulseaudio

Using $ alsamixer -Dhw shows the M-Audio card is recognised. The only software which works with sound at present is the VLC media player. I have noticed that the Sound preferences reset the default mixer to the VIA 8237 chip on the motherboard every time I log off and back on.

I may be trying to make something happen here which is far beyond my competence. However: if it is possible to point me in the right direction - simply, making no assumptions as to any programming or compiling knowledge - I would be grateful.

Peter Longhurst

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel T Chen
Solved:
2009-12-02
Last query:
2009-12-02
Last reply:
2009-12-01
Peter Longhurst (pslonghurst1) said : #1

Ignore this problem: I'll upgrade the ubuntu OS instead. Peter L

Best Daniel T Chen (crimsun) said : #2

If you use asoundconf (which is obsolete and unmaintained as of Karmic/9.10), you'll create ~/.asoundrc* which redefines pcm.default and ctl.default and nearly always causes problems for native ALSA apps [which are no longer routed through PulseAudio]. In short, don't use it if you want to use the default PA config. (Of course you can use them simultaneously; you just need to modify /etc/pulse/default.pa or ~/.pulse/default.pa to use dmix as the default sink and dsnoop as the default source.)

Use the new GNOME volume control applet to set the default (fallback) sink.

Peter Longhurst (pslonghurst1) said : #3

Daniel:

Thank you. I will try to follow this through to see what happens (to gain some experience at the very least), before I get on to upgrading to a later version of Ubuntu.

With regards

Peter L