Waiting for sound system to respond

Asked by Pierre Frenkiel on 2009-11-03

when I open System/Preferences/Sound, I get a window displaying the message:
   Waiting for sound system to respond
and nothing else.
My system: Ubuntu 9.10

I have 2 sound cards: 1 integrated Intel, and 1 SB Live. I uses the 2nd one,
and it works perfectly for output, but not for recording.
Before upgrading to Karmic, I had Intrepid, and everything worked correctly.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-11-14
Last query:
2009-11-14
Last reply:
2009-11-14

Try deactivating the integrated Intel sound card in the BIOS.

Then reboot and send us output from step 3 and step 4 from this procedure:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

John Doe (johndoe32102002) said : #2

Same problem but only one sound card with no options for it in the BIOS. Many other people have this problem and there is no working solution.

Tulasi (murtulasi) said : #3

I have same problem. I have only one sound card. Volume controller icon is missing. I cannot increase or decrease the volume and no sound can be heard at all. Any tips ....

DarkChoc4 (pomeroym) said : #4

There is a long upgrade here that worked for me on Karmic:
http://monespaceperso.org/blog-en/2009/08/31/upgrade-alsa-1-0-21-on-ubuntu-jaunty-9-04/

DarkChoc4 (pomeroym) said : #5

Same instructions, but it feels more comfortable, here's the Karmic link:
http://monespaceperso.org/blog-en/2009/10/29/upgrade-alsa-1-0-21-on-ubuntu-karmic-koala-9-10

hi Mark,
At last, I deactivated the integrated Intel sound, but it took some time, as the bios deactivation didn't work, and I had first to update the bios)
I then executed the SoundTroubleshootingProcedure.
After that, the original problem is not solved. I still get:
    Waiting for sound system to respond.
 the requested output is at http://pastebin.ca/1671116

I forgot to add that recording now works perfectly ...

@Pierre Frenkiel: I notice the following issue with your ALSA configuration:

Please unmute and increase volume to 77% on the Master, PCM and Front volume channels using alsamixer or gnome-alsamixer

Please install pulseaudio and paman using the following commands:

sudo aptitude update
sudo aptitude install pulseaudio paman

According to your output, pulseaudio is not installed and not running:

# Sound Servers on this system
# ----------------------------
#
# No sound servers found.

Please also send us output from step 4 from the following procedure:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

And finally, also perform steps 5 to 14 in the same procedure:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Then reboot and retest sound.

------------------------------------------------------------------------------------------------------------------------------------------------------
Your ALSA mixer output shows the following issue (muted volume channels):

# Simple mixer control 'Master',0
# Capabilities: pvolume pswitch pswitch-joined
# Playback channels: Front Left - Front Right
# Limits: Playback 0 - 31
# Mono:
# Front Left: Playback 0 [0%] [-46.50dB] [off]
# Front Right: Playback 0 [0%] [-46.50dB] [off]

# Simple mixer control 'PCM',0
# Capabilities: pvolume pswitch pswitch-joined
# Playback channels: Front Left - Front Right
# Limits: Playback 0 - 31
# Mono:
# Front Left: Playback 0 [0%] [-34.50dB] [off]
# Front Right: Playback 0 [0%] [-34.50dB] [off]

# Simple mixer control 'Front',0
# Capabilities: cvolume cswitch cswitch-joined
# Capture channels: Front Left - Front Right
# Limits: Capture 0 - 100
# Front Left: Capture 80 [80%] [-8.00dB] [off]
# Front Right: Capture 80 [80%] [-8.00dB] [off]

On Sat, 14 Nov 2009, Mark Rijckenberg wrote:

> Please unmute and increase volume to 77% on the Master, PCM and Front
> volume channels using alsamixer or gnome-alsamixer

   I did that since the beginning...
   As I said, the audio output worked, but not the recording.
   After running the Alsa upgrade procedure, recording worked, and
   only remained the problem with System/Preferences/Sound

> Please install pulseaudio and paman using the following commands:

   I did it, and after that, System/Preferences/Sound work almost
   perfectly.
   Just after my upgrade to Karmic the sound didn't work at all, and I got
   a lot of puleaudio error messages, even when I ran Xdialog.
   As at this time I was not aware of the Alsa upgrade procedure, the only
   workaround I found was to remove pulseaudio, which solved the
   problem with output. Curiously, reinstalling it solved almost everything:
   paman, padevchooser works. The only (minor) remaining problem is with
   pavumeter, which gives me: Connection failed: connection refused.

thanks for your cooperation.
--
Pierre Frenkiel

Hi,

pavumeter is not absolutely necessary to use. You can try using gnome-alsamixer instead.

If the issue is now resolved, can you please set the thread status to "solved"?

Thanks,

Mark

Hi mark,
I agree that pavumeter is not absolutely necessary, as there several alternatives, beside gnome-alsamixer, like aumix, alsamixer. It is just irritating to have
unexplained error messages...

Thanks Mark Rijckenberg, that solved my question.

John Doe (johndoe32102002) said : #13

I have fixed this problem by manually compiling the latest version of pulse. This re-enabled the sound to work again and my internal microphone (not supported previously) works.

Hi John,
I also did that (version 0.9.20), but that changed nothing for me, i.e.
everything works, but pavumeter. Is it working for you?

Mario Zama (mario-zama) said : #15

I had the same problem and I don't know why the .pulse directory in my home path had only root rights.
I just did a "sudo chown myuser:mygroup $HOME/.pulse" where myuser and mygroup are my account and group values and it was fixed.