pulseaudio and saa7134 audio device

Asked by smurf on 2009-09-24

On karmic Pulseaudio is really amazing, the new program for managing audio HW is fantastic, simply and easy to use.
Pavucontrol as well is ok and exactly with this program I discovered that Pulseaudio receive sound from my tvcard using SAA7134 drivers, because the output indicator is pulsing, so I wonder: if pulseaudio recognize the card and receive the audio from it, why the hell I can't hear nothing from pulse and I have to use sox to redirect the alsa output?

There is a way to use Pulseaudio to directly listen my tv on the standard audio output so if I want I can use my BT Headset?

Thx a lot for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
smurf
Solved:
2009-09-30
Last query:
2009-09-30
Last reply:
2009-09-30

If I catched that right you want to watch TV and hearing it's audio on your bt headset?

Check out this page, which describes how to set up your computer with pulseaudio well:
http://pulseaudio.org/wiki/PerfectSetup

If you decide to use Kaffeine for watching TV you properly just have to set your Bluetooth Headset as default at padevchooser before starting Kaffeine and thats it!

How to set up your Bluetooth Headset?
Take a look at these modules to use your headset with Pulseaudio:
http://pulseaudio.org/wiki/Modules#Bluetooth
or take a look at this bug:
https://bugs.launchpad.net/pulseaudio/+bug/405294

smurf (luca-dgh) said : #2

To use My BT headset would be the Top of the Top, but not the only target to reach.
Up to jaunty I understood that nor Alsa or Pulseaudio where able to properly detect and manage the SAA7134 audio channel, sox was the only way to redirect the audio from SAA7134 card to the standard audio output.

Now in karmic, I see with Pavucontrol that Pulse sense the audio from SAA7134 card, because the level meter pulse accordingly with the tv audio.
So I wonder: but if Pulseaudio sense the audio from SAA7134 card, why it can't be redirected to standard audio output?
That would be fine, because in that way tha audio from tv would pass trough the standard "mixer" and would be submitted to a standard management, that includes to be listened also with my BT headest.

Using Kaffeine would not be standard for me, I use Gnome, so I'd have to install a wide number of libraries and software and probably I' d need some dedicated commands and / or scripts only to listen tv trough BT, that is already done by Pulseaudio. Can you understand?

smurf (luca-dgh) said : #3

I reported this problem to Pulseaudio.org and they answered that in a future there will be a UI for this, meanwhile I have to load a "module-loopback" to digitally redirect the audio http://www.pulseaudio.org/ticket/665.
Can someone explain me how to do this on Ubuntu?

Thanks a lot for your help.

open your console then and execute

$ pactl load-module module-loopback

if you want to load this module with every start try that:

$ sudo sh -c ' echo "load-module module-loopback" >> /etc/pulse/default.pa '

when using the command below you really have to make sure that the right " or ' are place in the right order. If you have root permissions, by typing in sudo su for example you can leave out the sudo of the second command.

And remember if you load the module by

$ pactl load-module module-loopback

the module will only be loaded for that session that means that you will have to load
the module after the next reboot again.
The second command adds loading the module for the next reboot.

Don't forget to remove everytime the "$", because it just indicates here that the command befind it will work fine with user permissions.

smurf (luca-dgh) said : #5

thank you for your reply Thomas.
I tried giving the command from a terminal, it answered "22" (I suppose it is the number of devices recognized).
After that I found that from the speakers I could hear the sound from the mic integrated in my webcam, so the command had some effect. I muted the mic from Pulseaudio settings.
But from the SAA7134 device no sounds, I tried as well to launch tvtime with the command

tvtime --mixer=pcm:0

but the answer was:

mixer: Can't open device pcm, mixer volume and mute unavailable.
mixer: No such mixer channel '0', using channel 'line'.

I tried as well others devices like: Master, Line-in, and so on. But I got always the same answer from tvtime.
The funny is that now the level meter of the SAA7134 device in Pavucontrol, senses audio only if tvtime is running, otherwise is not pulsing.

Can you still help me please?
Thx a lot.

hmm I really have no clue how to solve that problem, but to your tvtime command..

the name pcm seems to be wrong so if tvtime is using alsa I would take a look at this:

http://pulseaudio.org/wiki/PerfectSetup#ALSAApplications

and create a device for pulseaudio in alsa and then point tvtime to --mixer=pulse
but I'm not 100%ly sure if that would solve your problem :/

Try to get in contact with the people on IRC:

http://java.freenode.net/index.php?channel=pulseaudio

If you have any other gerneral questions about pulseaudio you can be sure to get useful answers here for sure :)

smurf (luca-dgh) said : #7

ok, thx a lot again.

A bit more funny: I opened my skype and I realized that now instead of capturing from the webcam is capturing from the tv card.

It is better I ask to the people on the IRC.

I close this answer because is obviously a problem that have to been solved from them.

Cheers