Noise cancellation module not working

Asked by Kalpesh on 2019-12-28

I plugged my microphone to the ubuntu and while doing Skype calls, there is continuous noise. After searching online, I tried to add the noise cancellation profile but then pulseaudio stopped working.

Here is what I tried:
sudo nano /etc/pulse/default.pa
load-module module-echo-cancel

After this, when I opened pulseaudio after reboot, it stopped working. Showing the error message as:
"connection to PulseAudio failed. Retry in 5s" but it never worked. It starts working again if I remove that line.

After some more research, I tried this command:
pactl load-module module-echo-cancel

and it shows this output:
Failure: Module initialization failed

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2020-01-02
Last reply:
2020-01-18

What is the output of:

lsb_release -a; uname -a; apt-cache policy pulseaudio

Thanks

Kalpesh (kalpeshkhule) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic
Linux kalpesh-System-Product-Name 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
pulseaudio:
  Installed: 1:11.1-1ubuntu7.4
  Candidate: 1:11.1-1ubuntu7.4
  Version table:
 *** 1:11.1-1ubuntu7.4 500
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:11.1-1ubuntu7 500
        500 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.