PulseAudio not honoring the "avoid-resampling" option

Asked by Mark on 2018-08-25

So PulseAudio on Ubuntu 18.04 apparently does not honor the "avoid-resampling = yes" configuration option. That is the option to allow native sample rate playback with PulseAudio. When I set the option to either "yes" or "true" in /etc/pulse/daemon.conf, restart PulseAudio and check to see the active configuration (using --dump-conf), I get "avoid-resampling = no" every time.

I tried disabling PulseAudio daemonize mode and manually starting it from terminal, I tried setting the option globally and in ~/.config/pulse, I tried restarting the system after setting the option. No difference.

I believe this is a bug, as the option should definitely work, as it is available since PulseAudio 11. I'm running version 11.1.

Question information

Can you help with this problem?

Provide an answer of your own, or ask Mark for more information if necessary.

To post a message you must log in.