Trouble with pulseaudio

Asked by Ivan on 2009-02-13

I know that there are tons of information on the subject, but I'm stucked reading it.
Problem with sound what ever the media player is (Totem, Rhythmbox, Audacious, VLC):
10 sec of sound, 1 minute of silence, 10 sec of sound, 1 minute of silence, 10 sec of sound, 1 minute of silence... Most players, except VLC hangs, when sound stops.
Any ideas about the solution?

P. S. Some time ago I had had another problem with pulse audio and had solved it with http://ubuntuforums.org/showthread.php?t=776739&page=1.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-24
Last reply:
2009-02-24
Sam_ (and-sam) said : #1

Hi,
you may check system logs and start every app in a terminal to get some related messages.
.xsession-errors (hidden in home/user) can be helpful also.

Or set everything to ALSA and test all apps again.

http://www.pulseaudio.org/wiki/PerfectSetup
https://help.ubuntu.com/community/SoundTroubleshooting

In case
http://alsa.opensrc.org/index.php/TroubleShooting

The bug section might have helpful hints
https://bugs.launchpad.net/ubuntu/

Worse case
Reinstall PulseAudio

Ivan (somerussian) said : #2

Have set everything to ALSA in System->Settings->Sound, but bug still occurs.
I also tried to compile pulseadio 0.9.14 from source - error occurs during make, and I don't know what to do with it.
What next? Should I compile alsa from source?

Tom (tom6) said : #3

Sorry, i'm in a cyber cafe now & i can't really login to the ubuntu forum from this slow buggy multi-user Windoze 'landfill' machine.  I keep handy out the wiki page on how to trouble-shoot alsa problems but i haven't read it!  Shocking i know - i really must try working through the page myself.  Compiling or recompiling the source-code for even just 1 or 2 packages sounds like a technical nightmare to me but many people say "Solved" after i hand this page out.  It's got to be worth digging around the mixer gui and checking the sliders on all the different channels.  Also worth going up to the top taskbar and click on

System - Preferences - Sound

or is it

System - Administration - Sound

... but it looks like you've already tried all that.  I'm not really very techi except for a few things and sound isn't exactly my strong suit.  Good luck with compiling

Sam_ (and-sam) said : #4

Sorry, since I don't compile, instead installing via package manager and everything works fine, I'm not able to add something to my hints above.

Ivan (somerussian) said : #6

https://help.ubuntu.com/community/SoundTroubleshooting - to much to read there and I can't guess what is useful for me.

Tom (tom6) said : #7

Do each step in the order it's presented on the page and hopefully you'll have fixed the problem a long time before getting near the end of the page.

Good luck and regards from
Tom :)

Ivan (somerussian) said : #8

Well show me please how to find out the name of my soundcard driver.

Tom (tom6) said : #9

lol, you have a good point. There is an easy command but i don't know it. Please post that as a new question.

https://answers.launchpad.net/ubuntu/+source/pulseaudio/+addquestion

Good luck with this. Regards from
Tom :)

Sam_ (and-sam) said : #10

Hi,
first off, what is the sense to repeat links, when reading answers is appropriate?

Ivan, if reading tutorials and following the contents for troubleshooting is too much, please clarify your expectations, thanks.

To find sound card + driver(=module=alsa-driver=kernel module)
GUI:
System -> administration -> system log
e.g. in syslog with filter ctrl+f
type: intel

or install 'hardinfo' and search in 'Kernel Modules' for snd_xxx

CLI: ##note commands are case sensitive
lshw -C sound

Which card:
cat /proc/asound/cards
or
lspci | grep -i audio

Which modules are available:
find /lib/modules/`uname -r` | grep snd
or
modprobe -l | grep snd | grep pci

more specific e.g.:
modprobe -l | grep snd | grep via
or
modprobe -l | grep snd | grep intel

Can you help with this problem?

Provide an answer of your own, or ask Ivan for more information if necessary.

To post a message you must log in.