alsa / pulseaudio suddenly produces a stange kind of static sound, oss still works(HDA intel STAC92xx)

Asked by Jeroen on 2009-02-06

alsa / pulseaudio suddenly produces a stange kind of static sound, oss still works.
I'm running a up to date version of ubuntu intrepid on my dell latitude d830 laptop.
I also tried going back a kernell version. No effect.

Sound preferences displays my sound card as HDA intel STAC9205

lspci -v
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 01fe
 Flags: bus master, fast devsel, latency 0, IRQ 21
 Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: STAC92xx Analog [STAC92xx Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: STAC92xx Digital [STAC92xx Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
Jeroen
Solved:
2009-02-08
Last query:
2009-02-08
Last reply:
2009-02-07
Jeroen (c0p3rn1c) said : #1

uname -r
2.6.27-11-generic

Tom (tom6) said : #2

There might be some conflict between alsa and pulseaudio. I think als is generally the preferred one to keep and so it might be worth using this trouble-shooting guide to help
http://alsa.opensrc.org/index.php/TroubleShooting

I'm not sure about sound issues tho so good luck with this
Regards from
Tom :)

Tom (tom6) said : #3

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

Jeroen (c0p3rn1c) said : #4

I'm sorry Tom but I don't really have the time at the moment Tom. But I'll be sure to respond any questions on this thread ofcource.
I also think my standard was pulseaudio instead of alsa btw because I could playback sound with multiple programs at the same time, again not sure about that.
I think its very strange that everything was working perfectly untill +- last week, so I'm going to be a mystery for a while untill I have the time to put my teeth into the problem.

I did get the aadebug output though:

ALSA Audio Debug v0.1.0 - za feb 7 18:43:34 CET 2009
http://alsa.opensrc.org/aadebug
http://www.gnu.org/licenses/gpl.txt

Kernel ----------------------------------------------------
Linux jeroen-laptop 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

Loaded Modules --------------------------------------------
snd_hda_intel 492336 3
snd_pcm_oss 52608 0
snd_mixer_oss 25088 2 snd_pcm_oss
snd_pcm 99208 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 11524 0
snd_seq_oss 42368 0
snd_seq_midi 15872 0
snd_rawmidi 34176 1 snd_seq_midi
snd_seq_midi_event 16768 2 snd_seq_oss,snd_seq_midi
snd_seq 67168 7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 34320 2 snd_pcm,snd_seq
snd_seq_device 16404 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 79432 14 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc 17680 2 snd_hda_intel,snd_pcm

Modprobe Conf ---------------------------------------------
Warning: module config file does not exist
This means any kernel modules will not be auto loaded
See your linux distro docs on how to create this file

Proc Asound -----------------------------------------------
Advanced Linux Sound Architecture Driver Version 1.0.17.
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 21
  2: : timer
  3: : sequencer
  4: [ 0- 1]: digital audio playback
  5: [ 0- 0]: digital audio playback
  6: [ 0- 0]: digital audio capture
  7: [ 0] : control
cat: /proc/asound/hwdep: Bestand of map bestaat niet
00-01: STAC92xx Digital : STAC92xx Digital : playback 1
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2
Client info
  cur clients : 4
  peak clients : 4
  max clients : 192

Client 0 : "System" [Kernel]
  Port 0 : "Timer" (Rwe-)
  Port 1 : "Announce" (R-e-)
    Connecting To: 15:0
Client 14 : "Midi Through" [Kernel]
  Port 0 : "Midi Through Port-0" (RWe-)
Client 15 : "OSS sequencer" [Kernel]
  Port 0 : "Receiver" (-we-)
    Connected From: 0:1
Client 128 : "TiMidity" [User]
  Port 0 : "TiMidity port 0" (-We-)
  Port 1 : "TiMidity port 1" (-We-)
  Port 2 : "TiMidity port 2" (-We-)
  Port 3 : "TiMidity port 3" (-We-)
  Output pool :
    Pool size : 500
    Cells in use : 0
    Peak cells in use : 0
    Alloc success : 0
    Alloc failures : 0
  Input pool :
    Pool size : 1000
    Cells in use : 0
    Peak cells in use : 0
    Alloc success : 0
    Alloc failures : 0

Dev Snd ---------------------------------------------------
controlC0 pcmC0D0c pcmC0D0p pcmC0D1p seq timer

CPU -------------------------------------------------------
model name : Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz
cpu MHz : 1801.000
model name : Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz
cpu MHz : 1801.000

RAM -------------------------------------------------------
MemTotal: 2055812 kB
SwapTotal: 3742976 kB

Hardware --------------------------------------------------
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)

Tom (tom6) said : #5

Brilliant, thanks for your response. When you do repost the question make sure it's brief and posted just before people from america fill up the space in here & start answering questions ;)

Good luck and regards from
Tom :)

Jeroen (c0p3rn1c) said : #6

Upgrading alsa fixed it.View http://ubuntuforums.org/showthread.php?p=6589810#post6589810 for more info.

Tom (tom6) said : #7

Brilliant, thanks for getting back to here with the answer. hopefully now if people have similar problem they'll be able to see this and fix there own as you have. Nicely done, congrats
Regards from
Tom :)

Jeroen (c0p3rn1c) said : #8

Glad to be of help!

Tom (tom6) said : #9

We could always use another volunteer to answer questions as they arrive in the "Answers" section at launchpad. Seems like you're probably pretty good at helping people with sound issues by now!
Anyway, good luck and enjoy :)
Regards from
Tom :)

Jeroen (c0p3rn1c) said : #10

I wish I had the time, I would help linux people all day , love fixing problems =)