stream video problems & codecs

Asked by luxus on 2009-02-03

I have a problem and it comes from my lack of experience. As a new to linux I have messed up with the video codecs or so and the result is:

I can play .avi files in the computer
I can play videos on Youtube but without sound
I can't start watching a streaming video.

I have downloaded the ubuntu-restricted-extras dvdrip together and with those the videos on my computer play fine but still the problem with online videos and streaming TV/radio is still there.

I have tried to put Mplayer but this one messes up my videos on the computer as well.

In my opinion i should delete all the codecs and put back only the ones that I need.
If thats the case I would like to know how to do all that, or if you have a better solution for me I would like to hear it.

Regards, Angelos
OS: Ubuntu 8.10

Question information

English Edit question
Ubuntu pulseaudio Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Tom (tom6) said : #1

Sounds like you're quite used to using Synaptic Package manager now? Use one of the search tools to find and install a flash player (or two), i like gnash and the swf one but had to get adobe and stuff too. Maybe try re-installing Totem as that may draw some of the missing dependencies back in. Linux is usually slightly better about letting you just re-install stuff rather than having to uninstall-reboot-reinstall-reboot. Although sometimes you might need to logout and login again.

Best Tom (tom6) said : #2

With the sound tho, that's got to be an Alsa-mixer problem? Try right-clicking the speaker icon by the clock and "Open Volume Control" the Preferences button has a lot of different channels. Try adding in a few at a time to see if they are muted or something. YouTube used to remember my speaker settings when they were wrong for me but refuses to remember them when i got them right. You've checked the speaker icon within the youTube video itself? Next step is this i'm afraid

Regards from
Tom :)

luxus (xray-warface) said : #3

Hey Tom thank you for your super fast replies. If there is something that i love about linux is the huge support by its own people.

I don't think its the alsa mixer because when i reinstalled the restricted extras and the dvdrip the sound to my video came back. I still don't have sound on my youtube but at least I can watch my series for now. Another problem that I found is that when I call with skype after that my sound on the videos is lost, and if i close it the sound on the video starts. If I play a movie the same thing happens to skype. So this could be an alsa mixer problem.

I am pretty lost due to my lack of experience. I will try to download the gnash and see what happens. Whenever I tried to download something additional though I screwed something else in there so I will try to be careful from now on.

luxus (xray-warface) said : #4

Hey. A friend of mine helped me so I will share the info here.

The case was that I was running many players together that caused fraction.

After doing
sudo killall -9 gmplayer
sudo killall -9 pulseaudio

I found out that the video was working, stream was working and the skype was not interrupting anymore.

Thanks a lot for the time you got trying to help me. I really appreciate it.

Best regards,


luxus (xray-warface) said : #5

Thanks Tom, that solved my question.

Tom (tom6) said : #6

Brilliant, nicely fixed and thanks for crediting me with that ;)

Regards from Tom :)

luxus (xray-warface) said : #7

Anytime. Thanks for taking interest in my occasion!


Patrick M (prmillius) said : #8

Just downloaded the latest ubuntu update, firefox security etc, was included. Now stumble upon, you tube, etc. video won't play. no video nor audio. I need an updated plugin maybe?