PulseAudio does not detect ThinkPad R61 correctly

Asked by Kamil Páral on 2008-06-22

Binary package hint: pulseaudio

I have ThinkPad R61 and Ubuntu 8.04. In default installation there is a problem in simultaneous playing many audio sources:

 * Totem and Rhythmbox plays simultaneously (as any GStream applications)
 * Rhythmbox and most games (Extreme Tux Racer, Frozen Bubble) does not play simultaneously
 * Rhythmbox and flash videos does not play simultaneously

This is a sample error which displays frozen-bubble on start (similar errors show most games):

[SDL Init] ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
Warning: can't initialize sound (reason: No available audio device).

If I kill and restart pulseaudio, this error is shown in the terminal:

$ killall pulseaudio
$ pulseaudio
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

== Solution ==

I have edited /etc/pulse/default.pa and changed these lines:

### Automatically load driver modules depending on the hardware available
.ifexists module-hal-detect.so
load-module module-hal-detect
.else

to these lines:

### Automatically load driver modules depending on the hardware available
.ifexists module-hal-detect.so
#load-module module-hal-detect
load-module module-alsa-sink
load-module module-alsa-source
.else

After relogin problem is solved, rhythmbox, totem, games, flash videos, all play simultaneously. When pulseaudio is run in the terminal, there are no errors, only warnings:

$ killall pulseaudio
$ pulseaudio
W: alsa-util.c: Device default doesn't support 44100 Hz, changed to 48000 Hz.
W: alsa-util.c: Device default doesn't support 44100 Hz, changed to 48000 Hz.

There is clearly some problem when autodetecting ThinkPad R61 hardware. Please fix this. I can provide you with outputs of other commands, just tell me what you need.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
Kamil Páral
Solved:
2008-07-06
Last query:
2008-07-06
Last reply:
2008-07-03
Kamil Páral (kamil.paral) said : #1
Kamil Páral (kamil.paral) said : #2
Kamil Páral (kamil.paral) said : #3
Charles Profitt (cprofitt) said : #4

I tested the default install on my T61p laptop and did not have the same issue. I have attached the output of lspci. I am not sure what the chipset differences are between the T61 and the R61 but hope this could help determine if it is a hardware detection issue as was suggested by the OP.

Charles Profitt (cprofitt) said : #5

I just checked the Lenovo web site (http://tinyurl.com/5gj4yv) and the driver package for Windows is the same. Again I hope this helps.

Kamil Páral (kamil.paral) said : #6

I have found out that with my modified default.pa sometimes the pulseaudio does not start after login (maybe some pulseaudio error not related with this, who knows). Moving the two lines

load-module module-alsa-sink
load-module module-alsa-source

to the end of the file seems not to trigger this problem. I attach this modified file again.

Kamil Páral (kamil.paral) said : #7

Forget previous post, it's just some bug in pulseaudio, doesn't really matter how the configuration file looks like.

Charles Profitt (cprofitt) said : #8

I tested this on a new R61 and could not replicate the problem. I am converting this to a question so the user can get a resolution, but this no longer appears to be a bug.

Kamil Páral (kamil.paral) said : #9

That is really weird. I have Lenovo R61 8919-DEG. What type do you have, PrivateVoid? Not all R61 are the same.

By the way, by converting this to question all file attachments have been lost. Which is quite bad. And, it's not a question. I can handle the problem by mentioned workaround. I hoped programmers can fix the issue for other users.

Kamil Páral (kamil.paral) said : #10

It's all right, file attachments were not lost, they are in original bug report. So that's not a problem, sorry for misreporting.

Kamil Páral (kamil.paral) said : #11

I have just tried Ubuntu 8.04 from LiveCD and the problem is still the same:

$ killall pulseaudio
$ pulseaudio
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

Since it is livecd, it is all really in the default state. I strongly insist that this is a bug and should be solved. It may not be a problem on all R61 since there are a lot of versions, but on my R61 8919-DEG it is a problem. How can I convert this question back to a bug?

Kamil Páral (kamil.paral) said : #12

I have converted this question back to a bug #242103.

khiraly (khiraly123) said : #13

same problem (thank you Kamil for the fix) on an nx9105 laptop and with intrepid alpha6.

Should fix in pulseaudio I think. What commandare necessary?
lspci -vvvnnn
00:06.0 Multimedia audio controller [0401]: nVidia Corporation nForce3 Audio [10de:00da] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:006d]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (500ns min, 1250ns max)
 Interrupt: pin A routed to IRQ 21
 Region 0: I/O ports at 1400 [size=256]
 Region 1: I/O ports at 1c00 [size=128]
 Region 2: Memory at e8002000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: Intel ICH
 Kernel modules: snd-intel8x0

uname -a:
Linux buza 2.6.27-4-generic #1 SMP Wed Sep 24 01:30:51 UTC 2008 i686 GNU/Linux

pulseaudio:
ii gstreamer0.10-pulseaudio 0.10.10-1
ii pulseaudio 0.9.10-2ubuntu6
ii pulseaudio-module-hal 0.9.10-2ubuntu6

alsa:
ii alsa-base 1.0.17.dfsg-2ubuntu1
ii alsa-utils 1.0.17-0ubuntu2

might be this can help to setup pulseaudio apps...: http://www.pulseaudio.org/wiki/PerfectSetup

Hope this helps