Sound starts to stutter after some time logged in. Onboard Sound.

Asked by Hey! on 2015-10-27


First and foremost, I’m sorry for my English.

I'm having a problem with this card: " ". I'm using Ubuntu 14.04, but the same happens in 15.04.

After some time being logged in, the sound starts to stutter when i'm not doing nothing (idle).

I notice this especially when i'm listening music or seeing a video. I pause it, and leave the computer, but when i come back the sound is choppy.

Browser, media player, everything. Even the volume up/down "pop" sound is choppy after some time.

I tried installing a dedicated sound and it doesn't show this behaviour. Everything seems OK regarding this issue. The problem seems to be with the onboard sound and Ubuntu. This didn't happen on Windows so it doesn't seem a Hardware problem.

I also tried not disabling the onboard in the bios so that i could try both at the same time. When the problem started, i switched the headphone jack to the dedicated and selected it in the sound settings. The sound was OK again, but when i tried select back the onboard (and inserted the headphone jack in it), it was still stuttering.

The only way to stop this is to restart the computer. A log out and log in won't do it, but after some time is back.

The weird thing is that it only seems to happen when I’m not using the computer.

Does someone knows a way that i could diagnose what is happening?

Thank you very much.

Question information

English Edit question
Ubuntu pulseaudio Edit question
No assignee Edit question
Last query:
Last reply:

Click your own link.

It doesn't work.

Can you please post the whole URL.


Hey! (press-1p-start) said : #2


Thanks. It's fixed.

Hey! (press-1p-start) said : #3

Just to be clear:

The link it's fixed. Not the problem.


Try the below command:

echo "options snd-hda-intel power_save=10 power_save_controller=N" | sudo tee -a /etc/modprobe.d/alsa-base.conf > /dev/null

Reboot to test. The above is all one command, there is no break. Copy all the text

Hey! (press-1p-start) said : #5


Could you tell me what this command do?

I will try it with two sound cards (Dedicated and the onboard) activated. Does this command influence the other one behaviour?


It adds the text in the quotes to /etc/modprobe.d/alsa-base.conf

This will make the system not try and save power for the sound hardware and may resolve the issue. We can undo it by removing the line....

Hey! (press-1p-start) said : #7


I will try to see if it made a difference.

Just a question since i'm new to Linux.

If i open typed " sudo gedit /etc/modprobe.d/alsa-base.conf " in the command line and added " options snd-hda-intel power_save=10 power_save_controller=N " to the last line would it be the same as the command you posted?


Hey! (press-1p-start) said : #8

Sorry to ask you another question, but what is the value "10"?

Its a setting to make the power management ignore the device.

Yes, opening the file as root and adding the file is the same result.

Hey! (press-1p-start) said : #10


What if it was the value " 0 "?


Hey! (press-1p-start) said : #11


Unfortunately it didn’t work. It started stuttering again.

What is the difference between the value "10" and "0"?

Do i also need to change something in Pulseaudio?

Hey! (press-1p-start) said : #12

I just tried set it to 0, but the result was the same.

Can you help with this problem?

Provide an answer of your own, or ask Hey! for more information if necessary.

To post a message you must log in.