PULSE_SERVER does not redirect sound and/or redirected sound fails, eg mplayer says "AO: [pulse] Init failed: Connection refused"

Asked by gregrwm on 2012-10-20

i'm trying to forward sound to another box. works fine on natty, fails on quantal. eg mplayer says: "AO: [pulse] Init failed: Connection refused".

i have PULSE_SERVER pointing to a local port that i forward via ssh. this works under natty, and even while booted into quantal (with ssh launched from quantal), i can mount natty in a chroot, and forward sound via PULSE_SERVER. but outside the natty chroot, in quantal, it doesn't work.

i (intentionally) don't have pulseaudio installed, just pulseaudio-utils. if i remove everything in the home directory and /tmp for both quantal and natty, natty still works, quantal still doesn't.

what do i need to do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
gregrwm
Solved:
2012-10-26
Last query:
2012-10-26
Last reply:
2012-10-20

Did you upgrade from Natty to Quantal? And in one upgrade jump?

gregrwm (gregrwm) said : #2

i installed quantal core in a fresh partition and added lubuntu-desktop.

gregrwm (gregrwm) said : #3

after installing via quantal core, /etc/hosts was empty. the system worked otherwise, perhaps surprisingly. with the usual content in /etc/hosts, this problem resolved.

well, yeah. The system needs to talk to the pulse server via localhost, which needs to resolve to 127.0.0.1. I'm surprised anything worked at all. Even sudo needs this resolution to work.....