pulseaudio pa_pid_file_create() failed

Asked by Jaakan Shorter on 2007-12-05

Binary package hint: pulseaudio

Linux AMD64 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

upgraded from 7.10 to 8.04A1

in syslog there is a flood of the follow right after I rebooted

Dec 5 07:49:40 AMD64 pulseaudio[9028]: pid.c: Daemon already running.
Dec 5 07:49:40 AMD64 pulseaudio[9028]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:55 AMD64 pulseaudio[9090]: pid.c: Daemon already running.
Dec 5 07:54:55 AMD64 pulseaudio[9090]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:55 AMD64 pulseaudio[9093]: pid.c: Daemon already running.
Dec 5 07:54:55 AMD64 pulseaudio[9093]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:57 AMD64 pulseaudio[9096]: pid.c: Daemon already running.
Dec 5 07:54:57 AMD64 pulseaudio[9096]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:57 AMD64 pulseaudio[9102]: pid.c: Daemon already running.
Dec 5 07:54:57 AMD64 pulseaudio[9102]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:58 AMD64 pulseaudio[9106]: pid.c: Daemon already running.
Dec 5 07:54:58 AMD64 pulseaudio[9106]: main.c: pa_pid_file_create() failed.
Dec 5 07:54:59 AMD64 pulseaudio[9110]: pid.c: Daemon already running.
Dec 5 07:54:59 AMD64 pulseaudio[9110]: main.c: pa_pid_file_create() failed.
Dec 5 07:56:02 AMD64 pulseaudio[9133]: pid.c: Daemon already running.
Dec 5 07:56:02 AMD64 pulseaudio[9133]: main.c: pa_pid_file_create() failed.
Dec 5 07:56:02 AMD64 pulseaudio[9136]: pid.c: Daemon already running.
Dec 5 07:56:02 AMD64 pulseaudio[9136]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:21 AMD64 pulseaudio[9228]: pid.c: Daemon already running.
Dec 5 08:00:21 AMD64 pulseaudio[9228]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:26 AMD64 pulseaudio[9233]: pid.c: Daemon already running.
Dec 5 08:00:26 AMD64 pulseaudio[9233]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:26 AMD64 pulseaudio[9236]: pid.c: Daemon already running.
Dec 5 08:00:26 AMD64 pulseaudio[9236]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:26 AMD64 pulseaudio[9239]: pid.c: Daemon already running.
Dec 5 08:00:26 AMD64 pulseaudio[9239]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:32 AMD64 pulseaudio[9242]: pid.c: Daemon already running.
Dec 5 08:00:32 AMD64 pulseaudio[9242]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:37 AMD64 pulseaudio[9245]: pid.c: Daemon already running.
Dec 5 08:00:37 AMD64 pulseaudio[9245]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:41 AMD64 pulseaudio[9248]: pid.c: Daemon already running.
Dec 5 08:00:41 AMD64 pulseaudio[9248]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:44 AMD64 pulseaudio[9251]: pid.c: Daemon already running.
Dec 5 08:00:44 AMD64 pulseaudio[9251]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:44 AMD64 pulseaudio[9254]: pid.c: Daemon already running.
Dec 5 08:00:44 AMD64 pulseaudio[9254]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:44 AMD64 pulseaudio[9257]: pid.c: Daemon already running.
Dec 5 08:00:44 AMD64 pulseaudio[9257]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:44 AMD64 pulseaudio[9260]: pid.c: Daemon already running.
Dec 5 08:00:44 AMD64 pulseaudio[9260]: main.c: pa_pid_file_create() failed.
Dec 5 08:00:49 AMD64 pulseaudio[9263]: pid.c: Daemon already running.
Dec 5 08:00:49 AMD64 pulseaudio[9263]: main.c: pa_pid_file_create() failed.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2007-12-05
Last reply:
2007-12-06
Jaakan Shorter (jaakanshorter) said : #1
Jaakan Shorter (jaakanshorter) said : #2
Daniel T Chen (crimsun) said : #3

Are you using the per-user session method (not a system-wide daemon)? Even upstream recommends not using PA in system-wide daemon mode unless you well understand the implications. Further, Ubuntu will not enable this latter method by default.

Jaakan Shorter (jaakanshorter) said : #4

I don't even remember installing pulseaudio. I might have installed it via gstreamer but not directly

Daniel T Chen (crimsun) said : #5

This bug report implies:

1) the user did not install PulseAudio manually;
2) PulseAudio was somehow configured as a system-wide daemon, which is not the default method and not recommended.

Because neither of these symptoms indicate "supported" and normally sourced methods of using PulseAudio in Ubuntu 8.04, I'm converting this bug report into a question.

Hi all,

I see this same issue in a vanilla clean install of 8.04 so I think this will pop up may more times.

I have linked bug 108577 to this question as I believe it to be similar in origin however with 8.04 it's a built-in issue rather than something added / configued in by a user.

I am on an Intel chipset

Hope this helps, Rob

Can you help with this problem?

Provide an answer of your own, or ask Jaakan Shorter for more information if necessary.

To post a message you must log in.