Pulseaudio: how to auto start pulseaudio daemon at login

Asked by GIUSEPPE MASSETANI on 2011-11-25

Pulseaudio is included in Ubuntu 11.10 by default, you don't have to run it, I have been told. But, if I try to open Pulseaudio right at the beginning, from Dash, I receive this reply: "Fatal error. Unable to connect to Pulseaudio". So, my computer produces no sounds at all, and in the Sounds settings no device seems to be recognized, neither the microphone nor the woofers. The only way I have found out in order to solve this problem, is to open a terminal, and then enter the following command: pulseaudio -D
After this, everything works perfectly. Devices are detected by my PC, and all sounds can be heard. But, my question is: is this normal, or is there a bug in the programme????? I guess Pulseaudio should work automatically right from the very beginning, when I turn on my PC, and not exclusively via a terminal command line.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2011-11-28
Last query:
2011-11-28
Last reply:
2011-11-25

Be sure pulseaudio is starting using the Startup Applications Preferences tool:

http://shuffleos.com/3496/how-to-enable-all-applications-in-startup-applications-ubuntu-11-10/

Thanks marcobra (Marco Braida), that solved my question.