Ubuntu

pulseaudio strange behaviour

Asked by smurf on 2011-10-23

I have ubuntu 10.04 (AMD64), kernel 2.6.32-34.
In the last 15 days I found that Pulseaudio is not working as before. I have a TV card SAA7134, (since 3 years) that input the audio in line-in plug of the audio card. Suddenly has became mute, after surfing the web I found that I had to activate the loopback module, now is working. That is the first strange thing: suddenly loopback module has disappeared?
But now I have another problem: if I want to watch TV and listen it I have to select the line-in device in Pulseaudio preferences window, but in this way I can't use the mic with Skype and others chat software. To use the mic I have to go in the Pulseaudio preferences window and set the mic 1 option in the input device menu. Further, in this way I can constantly hear my voice in the speakers. That is annoying, Until 15 days ago (approx) ther was no need to make that choice, it was automatic.

How can I fix that ?

Thx so much.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
smurf
Solved:
2011-10-28
Last query:
2011-10-28
Last reply:
smurf (luca-dgh) said : #1

nobody has an answer?
Nor in Pulseudio mailing list they have an answer! Is it possible?
Pulseaudio sholud be the best achievemnet for an easy use of the sound machine on a pc, it should easily mix all the sound flows (this says the Pulseaudio web page), but actually Pulseaudio can't do a simple mix of two channels. Alsamixer was perfectly doing that mix.
Is this a progress or a regression???

smurf (luca-dgh) said : #2

nobody has an answer?
Nor in Pulseudio mailing list they have an answer! Is it possible?
Pulseaudio sholud be the best achievemnet for an easy use of the sound machine on a pc, it should easily mix all the sound flows (this says the Pulseaudio web page), but actually Pulseaudio can't do a simple mix of two channels. Alsamixer was perfectly doing that mix.
Is this a progress or a regression???

smurf (luca-dgh) said : #3

ok, problem fixed.
I removed Pulseaudio, now my linux box uses only Alsa stuff and even I see that cpu is less stressed than before.

I definitely think that Pulseaudio is garbage.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).