Ubuntu

pulseaudio doesn't find audio device when thinkpad_acpi module is loaded

Asked by Ulf Mehlig on 2011-06-05

When updating to Ubuntu 11.04/i386 I found a curious problem on a Lenovo Thinkpad R60 (might have existed in prior versions of Ubuntu, too):

pulseaudio did not find the audio hardware, and, consequently, there was no sound. Unloading the thinkpad_acpi kernel module manually, restarting pulseaudio and then loading the thinkpad_acpi module again solved the problem (now, .pulse/*something*default-source shows "alsa_input.pci-0000_00_1b.0.analog-stereo" etc.). I'm not sure whether to report this as a bug -- did anybody have a similar experience? Might have to do with the Thinkpad console audio control apparently provided by the module ...

Cheers, Ulf

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-05
Last reply:
2012-01-06

Can you please give the output of:

cd; wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh; chmod +x ./alsa-info.sh; ./alsa-info.sh

Thanks

Ulf Mehlig (umehlig) said : #2

you can access the output of alsa-info. sh at

http://www.alsa-project.org/db/?f=de50b1363fb845de4170a755b3f9f9bd0ff7ca01

(executed after "fixing" the problem as described above)

Try:

gksudo gedit /etc/modprobe.d/alsa-base.conf

add the line:

options snd-hda-intel model=thinkpad index=0

Save the new file, reboot to test

Frank Trenkamp (drw06-frank) said : #4

Hello,

had the same problem on a lenovo Thinkpad R60 and could restore sound with the above mentioned procedure (unloading thinkpad_acpi, restarting pulseaudio). Interestingly enough, on another (almost identical) R60 this never was an issue. That other R60 already ran on a system BIOS 2.23, the former R60 did not, but ran on 2.22.

By upgrading to 2.23 (latest BIOS as of today) not only sound works fine and immediately upon boot, but also the mouse is initialized correctly when first starting X. Before the update I had to restart X once (e.g. login/logout) to get a mouse pointer.

There are no ACPI changes listed for the BIOS, but it worked for me. Nothing else was changed, in particular no system configuration, module loading whatsoever.

Frank Trenkamp (drw06-frank) said : #5

Sorry - forgot to mention: Ubuntu version is 11.10 oneiric.

Can you help with this problem?

Provide an answer of your own, or ask Ulf Mehlig for more information if necessary.

To post a message you must log in.