My sound is way too loud

Asked by Steven Schveighoffer on 2011-02-22

When controlling the sound for my laptop, level 0, 1, and 2 create no sound.

However, at level 3 it goes from mute to FULL BLASTING VOLUME. There is very very little difference from 3 to 100%.

Some observations:

- Headphones act normally.
- Using alsamixer, I can watch how gnome adjusts the volume. It keeps PCM and LFE at 100%, and just uses the master volume
- Using alsamixer, if I set LFE to 0, then the sound seems to more correctly follow what the Master slider says.
- I found I have 3 speakers on my laptop. The speaker on the bottom appears to be the LFE speaker, but it does not obey the master volume control except whether it's on or off. Essentially, if master is at 0, it's off. But if master is at 1 or higher, it obeys only its own slider. Since pulseaudio keeps it at 100%, it means full blast all the time.

So I essentially have to use headphones when I want to listen to sound, so as not to annoy my colleagues. This is quite annoying.

I would like to just disable the LFE channel, but I realize that would not be a good general solution. However, could the LFE channel be adjusted as master volume is increased? That is, the LFE volume level would be set identically to the master volume level? I really can't seem to find any config options that allow me to change how pulseaudio changes the mixer levels. Are there any such configuration settings? Is it something external to that?

-Steve

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pulseaudio Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-02-22
Last query:
2011-02-22
Last reply:
2011-02-22

What make and model is the laptop???

Can you also give the output of:

lsb_release -a;uname -a

Thanks

What a moron I am! I forgot all that stuff...

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
Linux steve-laptop 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux

The model is a Dell Inspiron E1705.

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/410948

Has some fixes which people say worked.

#52 seems like it will work.

In future instead of typing "my laptop" use the ACTUAL make and model, it speeds stuff up a lot and gets you faster help.

Thanks actionparsnip, that solved my question.