value of /proc/sys/sunrpc/tcp_slot_table_entries is unusually low

Asked by Michael Gutteridge on 2013-01-10

The value for /proc/sys/sunrpc/tcp_slot_table_entries seems unusually low on 12.04.1LTS. The default seems to be 2:

root@g:~# sysctl sunrpc.tcp_slot_table_entries
sunrpc.tcp_slot_table_entries = 2
root@g:~# sysctl sunrpc.udp_slot_table_entries
sunrpc.udp_slot_table_entries = 16

We have had NFS performance issues, but had believed this to be rooted on the server side. However, I've recently been looking at mountstats(8) and am seeing high backlog wait times for all operations. This led me to that tunable.

So the question is why is it so low? Do I need to be aware of anything specific to Ubuntu before increasing it? I'm wary because 16 is typically the default, so why is it different on Ubuntu? Or am I missing something else?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu procps Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-01-10
Last query:
2013-01-10
Last reply:
2013-01-10

You can set the values as you want in /etc/sysctl.conf if you believe this is an issue, I recommend you report a bug

Michael Gutteridge (mrg-d) said : #2

Filed a bug. We'll be setting this for our hosts after we've verified that increasing the value improves our situation.

Thanks

Michael Gutteridge (mrg-d) said : #3

Thanks actionparsnip, that solved my question.

Michael Gutteridge (mrg-d) said : #4

Just a note for future Michael and others who might run into this. Adding the parameter to sysctl.conf doesn't work. sunrpc isn't loaded at that time (I think). Needs to be added to /etc/modprobe.d somehow. I've got a file called sunrpc.conf with the line:

options sunrpc tcp_slot_table_entries=16

That makes the change persistent.