PERMISSION DENIED

Asked by Christophe NAUD on 2011-02-21

I have installed AVAST. Yet AVAST will not run (invalid argument)
I have tried copy/pasting this line to the terminal:sysctl -w kernel.shmmax=10000000
answer: PERMISSION DENIED ON KEY 'kernel.shmax'
??????
Thank you in advance for all help and trouble.
contact: <email address hidden>

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu procps Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-21
Last reply:
2011-04-14

I have no idea if you *should* be setting kernel.shmmax to 10000000. If you can provide more information about why you're trying to do that (for example, a link to a website that says you should do that), then it might be possible to better judge that. But assuming that's what you want to do, you can do it by running the command:

sudo sysctl -w kernel.shmmax=10000000

The "sudo" makes the command run as root instead of as your limited user account. You may be prompted for your password. As you enter it, you won't see any placeholder characters (like *). That's OK, just type it in and press enter.

 Hello
Thanks for the answer. The idea is to run AVAST antivirus with Ubuntu.
I have already downloaded it but it will not run. Each time I try, it says :' an error occured in AVAST engine :invalid argument'.....

I presume you're posting again because (a) you're unsure of whether or not to run the command I gave you, to set kernel.shmmax to 10000000, (b) you ran it and got an error, or (c) you ran it, didn't get an error, but your underlying problem with Avast is not solved. Please specify which of these is the case (or if it's something else), and please also answer the following questions:

(1) For Avast, are you following instructions that are publicly available on the Internet? If so, please post a link to them. If not, please describe all the steps that you are following, in detail.

(2) Why do you want to set kernel.shmmax to 10000000? Did your instructions say to do this? Did they say to do this in response to an error? Is the error they say to do this in response to the same as the error you are experiencing?

(3) Are you attempting to run Avast in a Terminal window? If not, please explain how you are attempting to run Avast, and how the error message is displayed, and please include the full and complete text of the error message. If you are attempting to run Avast in a Terminal window, then please copy all the text from the Terminal (i.e. the *complete* contents of the Terminal window) and paste it here. (You can do Edit > Select All followed by Edit > Copy, in the Terminal window.) That should provide some useful information. If you are attempting to run Avast from a Terminal window but you have already closed the Terminal window, please open a new one, attempt to run Avast, then select all the text, copy it to the clipboard, and paste it here.

Many many thanks Eliah.
Avast still refuses to fully install on Ubuntu
here is a link from where I have found the command line:
http://sukiprattle.blogspot.com/2010/07/solved-avast-home-edition-in-ubuntu.html
By the way, I perhaps need say I have the Maverick Meerkat ( Ubuntu 10.10)
I am not sure, but this may be part of the explanation why Avast will not install and run....
Am I trying to run Avast in a Terminal window? the answer is no. I have the Avast icon on the screen
But every time I click on it, a window pops up and reads : an error occurred in Avast! engine: invalid argument.....

Are you still experiencing this problem? When you made your last post, you did not set the question's status back to Open (i.e., you clicked Just Add a Comment), but perhaps that was a mistake. Do you still want help?

Hello Eliah
I have other problems now. I have lost my connection with ubuntu.
A few days ago, everything was working just fine and I was able to connect to the web and listen to the radio.
But I lost my connection and a friend told me I was running an unstable versiion of Ubuntu. I still find this strange because I am dead sure I had downloaded the Meerkat from the official Ubuntu website.
Anyway, I have now installed Lucid Lynx (10.04) but have not got my connection back. And what is more, cupswrapper has gone (the driver for the Brother DCP 350 C) and some rhythmbox plugins are missing also. I can no longer connect to the web, I can no longer listen to music and i can no longer print anything.

It seems likely that your friend was mistaken. In particular, if you were running Ubuntu 10.10 Maverick Meerkat, the only possible way you could have been running a development ("unstable") version would be if you had installed it before its release date and never updated it since that date. Not only does this seem unlikely, but also, updating your system would immediately address that problem!

Since you cannot downgrade from Maverick to Lucid, I am guessing that you have erased your Maverick system and performed a fresh installation of Lucid. While it is true--and perhaps this is the kernel of truth in your friend's highly probable confusion--that Long Term Support releases tend to be (and are intended to be) more stable than non-LTS releases, that is not universally true, and in particular, there is plenty of hardware that is better supported by newer releases than older releases.

If you have wiped out your Maverick system and installed a Lucid system which is more badly broken than your Maverick system ever was, and updating the Lucid system doesn't fix the problem, then I'd recommend wiping the disk and reinstalling Maverick. (You don't need to do this as two separate steps--you can just pop in the Maverick install CD/DVD/USB and tell it to install Ubuntu using the whole disk--it will warn you that this involves losing all other operating systems on the disk, which is what you want. Unless you have another operating system, such as Windows, which you want to keep. Then don't do that--instead, either manually partition, removing the partitions associated with the previously installed Ubuntu system...or, select Try Ubuntu instead of Install Ubuntu, go to System > Administration > GParted Partition Editor, and remove the partitions associated with your Ubuntu system before installing. If you need help with any of this, please feel free to ask.)

That will likely fix all of your problems...but it should at least get you back to having less serious, rather than more serious, problems.

Can you help with this problem?

Provide an answer of your own, or ask Christophe NAUD for more information if necessary.

To post a message you must log in.