Unable To Configure Internet Connection With Wireless ADSL Modem

Asked by freebie on 2009-07-14

I run this into terminal:

sudo pppoeconf

and got this error:

Sorry, I scanned 2 interfaces, but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem.

My modem is wireless ADSL. I really don't have any idea of what should I do. Kindly request assistance on this matter. Let me know if I should put any details here.

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pppoeconf Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-07-23
Last query:
2009-07-23
Last reply:
2009-07-23

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Run the following command. The command STARTS with the word sudo and ENDS with the word restart. So please copy-paste the ENTIRE command below into a Terminal, press enter, then enter password when sudo asks for password, then press enter again.

sudo lshw -C network; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; uname -a; dmesg | grep ound; dmesg | grep b43; iwconfig; sudo /etc/init.d/networking restart

Step 3: Please post results (copy/paste terminal output) on this thread

Step 4: Please also specify the exact model and make of your PC (if known) on this thread

Step 5: Please also specify the exact model and make of your wireless ADSL modem (if known) on this thread. Can you connect your pc to the ADSL modem using an ethernet cable, a USB cable or are both types of wired network connection possible?

Regards,

Mark

freebie (myaz-resources) said : #2

Hi Mark,
Thank you for your quick respond.

I've followed through your steps, these are the result:

STEP 3
result that I copied from terminal:

 *-network
       description: Ethernet interface
       product: L1 Gigabit Ethernet Adapter
       vendor: Attansic Technology Corp.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: b0
       serial: 00:1b:fc:fb:96:73
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1 driverversion=2.0.7 duplex=full firmware=N/A ip=192.168.1.2 latency=0 link=yes module=atl1 multicast=yes port=twisted pair speed=100MB/s
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: vboxnet0
       serial: 00:76:62:6e:65:74
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

vboxnet0 Interface doesn't support scanning.

ppp0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

STEP 4

The exact model and make of my PC

Mm, I don't really know about this one, but hope these would help:

Hardware

Intel Core 2 Duo 2.4 E4600

Memory 2.0 GiB DDR

Motherboard ASUS P5K SE

AMD PCNET Family PCI Ethernet Adapter

and I'm using Ubuntu Hardy Heron with kernel linux 2.6.24-24 generic

STEP 5

Exact model of ADSL Modem

Wireless ADSL Modem 2/2+
DB108-WL

Features:
    * No computer resource occupation, downstream 24Mbps, upstream 1Mbps, switch able to ADSL2/2+
    * Routing from WAN to LAN
    * Support 1483 Bridge, PPPoA and PPPoE
    * Support up to 254 simultaneous user
    * Web-based GUI
    * Embedded software for connection status real-time supervision
    * Comply with main DSLAMs
    * Easy Installation with Smart Configuration
    * Tested with All 18 TM DSLAM
    * Lightning Protector Circuit.
    * SIRIM Approved, TM Approved and TM R&D Approved
    * Web-based Configuration and monitoring
    * Software upgradeable
    * Universal Plug and Play (UpPnP)
    * Firewall, IP Filter, Parental Control

Supported Protocols:
    * RFC 2364 PPP over ATM AAL5 (PPPoA)
    * RFC 2516 PPP over Ethernet relay ( PPPoE)
    * RFC1483 LLC&VCMUX (bridge and routing mode) multi-protocol encapsulation over ATM AAL5
    * RFC 1577 classical IP and ARP over ATM
    * ATM AAL5 UBR&CBRR
    * Supports ADSL, ADSL2 and ADSL2+, up to 24Mbps
    * Supports IEEE802.11b/g 54Mbps Wireless
    * Support diagnostic function

I'm using ethernet cable to connect to my PC.

Hi,

I suggest following these instructions to access the web-based configuration page of your ADSL modem:

http://modemsupport.blogspot.com/2008/08/riger-db108-wl-wireless-adsl-modem-22.html

Check the "DSL status" screen on the router and make sure you are getting an active signal from your Internet provider. Make sure the PPP login and password (given by your ADSL provider) is entered correctly.

If you are sure that you have a working Internet connection using the modem, please send the output of the following commands, using a wired connection to the modem:

sudo ifconfig
sudo iwconfig
ping -c 5 www.google.com
ping -c 5 209.85.227.103
cat /etc/resolv.conf

Regards,

Mark

freebie (myaz-resources) said : #4

I am so confused here. I've all hardware connection done correctly. Then I go to modem configuration settings at http://192.168.1.1 to store my account info (username and password). After save/reboot the modem, all the indicators are ON except for Internet indicator. On the connection summary it shows that my internet is not connected. I'm very confused, is it because of the ISP or is it because of pppoe not configured?

However, I've followed through the steps above. This is the output:

sudo ifconfig
eth0 Link encap:Ethernet HWaddr 00:1b:fc:fb:96:73
          inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21b:fcff:fefb:9673/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:1240 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1351 errors:0 dropped:0 overruns:0 carrier:7
          collisions:0 txqueuelen:1000
          RX bytes:649898 (634.6 KB) TX bytes:180724 (176.4 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:3642 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3642 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:182100 (177.8 KB) TX bytes:182100 (177.8 KB)

ppp0 Link encap:Point-to-Point Protocol
          inet addr:10.176.162.11 P-t-P:10.6.6.6 Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
          RX packets:2296 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2520 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1935877 (1.8 MB) TX bytes:393305 (384.0 KB)

sudo iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

vboxnet0 no wireless extensions.

ppp0 no wireless extensions.

ping -c 5 www.google.com
ping: unknown host www.google.com

ping -c 5 209.85.227.103
connect: Network is unreachable

vboxnet0 no wireless extensions.

ppp0 no wireless extensions.

cat /etc/resolv.conf

zaryn@zaryn-desktop:~$ ping -c 5 www.google.com
ping: unknown host www.google.com
zaryn@zaryn-desktop:~$ ping -c 5 209.85.227.103
connect: Network is unreachable
zaryn@zaryn-desktop:~$ cat /etc/resolv.conf
### BEGIN INFO
#
# Modified_by: NetworkManager
# Process: /usr/bin/NetworkManager
# Process_id: 5113
#
### END INFO

nameserver 192.168.1.1

Back to my first post here, I couldn't configure pppoe and it gives this output:

Sorry, I scanned 2 interfaces, but the Access │
          │ Concentrator of your provider did not respond. Please │
          │ check your network and modem cables. Another reason │
          │ for the scan failure may also be another running pppoe │
          │ process which controls the modem.

Hi,

I suspect your Internet Service Provider is having problems giving you a working Internet connection. Better call them first. You also have to make sure to install ADSL filters on ALL your phone sockets in the house before connecting the ADSL modem to the phone socket.

It is also possible that you have too much "noise" on your phone line. Please call the helpdesk of your ISP to get the Internet link back up and running.

I don't think this Internet connection issue has anything to do with your pc or Ubuntu, because the problem already occurs on the router, which resides between your Internet Service Provider and your PC.... So the problem is likely somewhere on the ADSL phoneline or at the ISP side....

Regards,

Mark

freebie (myaz-resources) said : #6

Thanks Mark Rijckenberg, that solved my question.