Can't connect to Internet (Jaunty with DSL)

Asked by Mugsy323 on 2009-05-09

Rather than upgrade my 8.04 installation (upgraded from 7.10), I installed Jaunty 9.04 via a clean reformat. Upon installation, I ran "sudo pppoeconf" to get online using my wired DSL connection. I even installed WINE. Everything seemed fine.

When I rebooted, I could not get online. I've re-run pppoeconf numerous times since then (accepted all defaults), which ran normally, but no connection when finished. I've tried "pon dsl-provider" (with and without sudo), which likewise results in no connection.

I right-clicked the "Network Connections" icon (upper right of toolbar) and added my info on the DSL tab, but it says "never" after the connection name on the menu, which I assume is the status, but I can't figure out how to change it. (BTW: If I check "All users", everything I typed is forgotten and I must re-enter the info all over again.)

I've tried entering my IP's DNS server numbers in the IPv4 section, which had no effect.

"ifconfig eth0" doesn't give me much useful info, and I can't ping anything from the Networking app. Nor can I install "Wicked" (WICD) from the Synaptic Package Manager (as suggested by an earlier question here) because it wants to download it from the Net.

Help. I'm stumped. Short of reinstalling 9 (or even going back to 8.10), does anyone have any idea of how to get back online? (typing this from XP on same computer).

Setup:
Jaunty v9.04 64bit dualbooting with XP and Win7
wired DSL connection.
Phenom II 920 processor and 2GB ram.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu pppoeconf Edit question
Assignee:
No assignee Edit question
Solved by:
Mugsy323
Solved:
2009-05-11
Last query:
2009-05-11
Last reply:
Mugsy323 (ambrosia-1) said : #1

I was able to get my DSL connection working only after reinstalling Jaunty and doing the following:

*******************
Notes:
1) The word "never" that appeared after your connection describes "the last time you were connected". When you are connected, it will change to "Now".)

2) Jaunty now uses the "Network Connections" app to manage your network connections (presumably, you can now have more than one), so if you used "pppoeconf", you've already doomed yourself. Before you go through the pain of reinstalling, try deleting the config file pppoeconf creates before going through the extreme step of reinstalling Ubu9 from scratch. Then set up your DSL the "proper" way via the NC app (on the toolbar). If that works, let us know.
********************

Upon reinstalling Ubu, right-click the "Network Connection" icon and "Edit connection". Click the DSL tab and enter your username and password (I don't know if it matters, but I entered my ISP's .com name on the "Service" line.) Check "Connect automatically" and change the name of the connection to something you'll recognize. Close the app.

Left-click the "Network Connection" icon and the name you gave your connection should be listed. Click it to get online. The icon should change to show two rotating arrows while it tries to connect. Once it does, the icon will change to the standard small "double monitor" connection icon you're familiar with.

I'm typing this from memory, so let me know if I've forgotten/missed anything.

Mugsy323 (ambrosia-1) said : #2

Quick update to Note #2:

How to delete your pppoeconf config settings without reinstalling Ubuntu. From the Terminal, try:

sudo apt-get --purge remove pppoeconf

Walter (walter-sebron) said : #3

Hello,

I seem to have a similar problem, but with my WLAN connection.

I just bought a "Point-of-view" 10" netbook with Intel Atom N270, 1GB DDR, 160GB SATA, integrated LAN/WLAN card and no CD or DVD Drive. It had Ubuntu 8.10 Intrepid Ibex installed.
Since coming from the MS world (sorry ;-) ), I'm completely new to Ubuntu/Linux, it took me a while to get the WLAN connection going. Everything worked fine then, as I got the info that there are SW updates available. So I updated to Ubuntu 9.04 Jaunty Jackalope.

Now there is no wireless connection possible anymore (I'm typing this on my MS Vista Notebook). I tried to follow the above instruction: Right-click on "Network connections" icon, click on "Wireless" Tab, and there was my wireless device already listed (Thomson wireless router). I selected the Thomson, clicked on the "Edit"-button and now don't know what to do next:
In the "Editing Auto Thomson" Window the "connect automatically" option was ticked already. However, there was no automatic connection with Jaunty Jackalope so far.
Below this option there are 3 tabs, "Wireless", "Wireless Security", and "IPv4 Settings":

- On the "Wireless" tab there are 5 data fields:
      - "SSID" containing "ThomsonFBxxx" as entry,
      - "Mode" containing "Infrastructure",
      - "BSSID" being empty,
      - "MAC Address" empty, and
      - "MTU" containing "automatic" bytes.

- On the "Wireless Security" tab there are 2 data fields:
      - "Security" containing "WPA & WPA2 Personal",
      - "Password" containing a different password than mine; if I change it to my own WPA PSK password and "Apply" it, nothing happens. Upon reopening this edit window, there is again the different password.

- On the "IPv4 Settings" tab there are 5 data fields:
      - "Method" containing "Automatic (DHCP)" as entry,
      - the rest is empty.

Below these tabs there is also the "Available to all users" option, ticking it had no effect as well.

What can I do next to get the connection running? Please bear in mind that I'm really new to Ubuntun and my last use of Unix is ages ago ...

Thx in advance,
Walter