pppoeconf problem

Asked by Martin Thomas on 2006-10-07

I *think* I now have Ubuntu installed (see query 2001). But the system seems unable to recognise the ADSL modem (D-Link DSL-302G). Anyway, it does not connect to the internet.

I tried pppoeconf (as recommended by Marcel Gagne's book "Moving to Ubuntu", pp.143-4).

It says it can recognise the Ethernet card, but the "Access Concentrator" (what?) can't find anything.

All the relevant lights on the modem light up. I've checked the cables several times.

I phoned Optus (the company supplying the ADSL connection). Their helpline person said that DHCP is not working (it certainly isn't), but she knew nothing about how to fix that in Linux. Her best suggestion was that I should reinstall Ubuntu.

Is it likely that this is a faulty installation? Or something to do with:

https://launchpad.net/distros/ubuntu/+source/pppoeconf/+bug/54383

Or is there something else I can try?

Question information

Or should I be using pppoeconf at all? At I read:

All PPPOE and router-style ADSL modems are supported by Ubuntu (that use ethernet for the connections), and some USB ADSL modems are supported too. For router-style ADSL modems, just connect it up, configure the modem as per your ISPs instructions and configure networking in Ubuntu. For information on PPPOE modems see this guide on the Ubuntu wiki.

How do I tell whether the modem - D-Link DSL-302g - is "PPPOE" or "router-style"? And if it is "router-style", how do I "configure the modem as per your ISPs instructions and configure networking in Ubuntu"?

When I try to look at networking in Ubuntu, it says, basically, that it has an Ethernet card but it's not connected to anything. When I ask for my "ISP's instructions", they say "Linux? Don't know. You're on your own".

Or is it that I am missing a driver for this modem? http://support.dlink.com/products/view.asp?productid=DSL%2D302G%5FrevC says drivers are available for the modem for Windows but not for Linux.

But https://help.ubuntu.com/ubuntu/desktopguide/C/hardware.html says: "All PPPOE and router-style ADSL modems are supported by Ubuntu (that use ethernet for the connections)..."

http://support.dlink.com/products/view.asp?productid=DSL%2D302G%5FrevC says: "The DSL-302G supports Static IP, Dynamic IP, as well as PPPoE connections terminating on the local PCs", which still leaves me wondering whether this is a "PPOE" or "router-style" modem.

Luca Falavigna (dktrkranz) said : #3

Do you use an Ethernet cable to connect to your device or an USB one?

An Ethernet cable.

In the meantime:

1. Firefox started working without me having done anything.
2. Firefox then stopped working without me having done anything.

It looks like some of the problem may be connected to a switch.

I also have a Windows XP computer (borrowed) connected to the modem. The modem is connected to a switch, then both computers to the switch.

Although all the relevant lights are lit up on the switch, it seems that if one computer has a working internet connection, the other doesn't, and vice versa.

That isn't all there is to it though, because earlier on I tried cutting out the switch and plugging the Ethernet cable from the computer running Ubuntu directly into the modem, and couldn't get a connection then.

I tried sudo ifup eth0 and it told me that the Ethernet connection was already activated.

I tried http://10.1.1.1 (see http://www.wlug.org.nz/DSL-302G). No setup necessary (I think because I'd already done that on this modem before the computer was rebuilt, using Windows). I just got a modem status page, which claimed that everything was fine.

And, indeed, Firefox started working on this machine. For a short while I had internet access on both computers. Now it's gone down on the other computer (without me doing anything, without any obvious reason, and with Windows telling me that the other computer's Ethernet connection is fine).

Now I've shut down my computer (the one running Ubuntu) and, without me doing any more, internet access is working again on the borrowed one (running Windows XP). So it's something to do with the switch.

Quoting from your other ticket: "Briefly, I have an Ethernet card connected via an Ethernet cable to a 5-port switch which in turn is connected to a D-Link 302g ADSL modem." - So it is not to do with drivers.

The problem could be to do with the actual networking set up. Are you using DHCP or a fixed IP? That is rather crucial information at this point, as you may have actually been trying to grab the same IP address as somethign else, and that just wont do...

What is the output of "sudo ifconfig -a"?

System>Administration>Networking>Ethernet connection>Properties shows Configuration: DHCP.

As I understand it, that means I'm using DHCP.

sudo ifconfig -a gives the following output:

martin@martin-desktop:~$ sudo ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:11:D8:78:BF:74
          inet addr:211.29.171.85 Bcast:211.29.171.85 Mask:255.255.255.255
          inet6 addr: fe80::211:d8ff:fe78:bf74/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:2773 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2302 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2848208 (2.7 MiB) TX bytes:294614 (287.7 KiB)
          Interrupt:209 Base address:0x8800

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:301 errors:0 dropped:0 overruns:0 frame:0
          TX packets:301 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:63808 (62.3 KiB) TX bytes:63808 (62.3 KiB)

sit0 Link encap:IPv6-in-IPv4
          NOARP MTU:1480 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Sorry again: I have to go to work now, and my next timeslot for trying to sort all this out is Monday evening local time, Monday morning GMT. But I really appreciate the help.

peter b (b1pete) said : #10

not quite the same situation but v close.

the question was and still is why can't the router (nat), working with no glitches on a win lan, be logged in or pinged from ubuntu 606 amd 64 live cd? dhcp works with no problems under win; all pc's are connected to the lan and internet yet ubuntu does not see the router and obviously no internet conn'n.

secondly, why Kubuntu -same 606 distro- sees the router without any problem and in so doing allows unimpeded internet access?. so far this situation is a big mistery.

peter b

Paul Rutledge (paulrutledge) said : #11

  I have the same problem, same modem, same provider.
  I have partly solved the problem by every time I start go to System, Administration, Networking
    select default gateway, eth0, twice sometimes to ensure it remains up
    select the ethernet connection, select properties, ensure DHCP is displayed
    select ( unselected ) enable this conection, select again enable this conection ( ticked )
    click OK
  ethernet conection will restart
  ensure gateway still eth0, click OK and you should be conected
  The problem is it does not save the configuration, so it has to be done after every shutdown

Luca Falavigna (dktrkranz) said : #12

Since DHCP suffers from some unresolved bugs, I suggest to use a static IP configuration. Pay attention there is another boring bug involving default gateway in Edgy.

That sounds fairly serious Luca. Can you link those bugs with this? They probably need to be bumped to major I would have thought..

peter b (b1pete) said : #14

Tx Paul for your suggestion!

I gave it a try but .... no cigar. I repeated it several times; what I've got was a bumping left to right bullet for something like 1 minute in a new window 'Activating interface "eth0"' that disappeared with no message of yey or ney left. I opened the browser and entered my ISP's home page url and got the same message 'Server not found, Firefox can't find the server at ......' as before.

Again, why ubuntu's brother Kubuntu hit the bulls eye and ubuntu missed? are the ubuntu brothers estranged of each other? don't they talk to each other and share info's and howto's?. to be honest I'm totally puzzled. and, to add more to this saga, it appears that there's no relief in sight -even the new Edgy will inherit the same situation.

peter b

Seems my personal problem is fixed. Not a Linux problem at all. A modem problem. The modem has the capacity to serve more than one computer, through a switch, but Optus supply it with that capacity switched off. So I've switched it on, and things seem OK.

However, Paul's and Peter's similar problems are not fixed, and presumably neither are the unresolved bugs in DHCP which Luca refers to. So leave this one open for a while.

Luca Falavigna (dktrkranz) said : #16

Bugs linked.

peter b (b1pete) said : #17

i agree with you 100% Thomas -leave these tickets open along with Paul's similar problems. maybe somehow this chorus will be heard somwhere by somebody. Thanks Luca and Danny for your help and voice of support.

I continued my investigations into this puzzling situation -ubuntu vis-a-vis Kubuntu- the first one having problems while the second one just sails through the autodetection/configuration process of the router. maybe the ubuntu ethernet driver (Nvidia's linux ethernet) is an older version than Kubuntu's??. Nvidia for sure has at least 2 versions of same driver and Kubuntu uses the newer version??. or maybe Kubuntu queries the router differently than ubuntu?. For sure only the os developers can find a resolution to this annoying situation.

Luca, you mentioned using static addresses to overcome the proper router detection. What should I use -the ISP's IP and DNS addreses before the translation by the NAT?. Tx

peter b

Peter (and others), presuming you have a Ethernet base ADSL router, you can normally configure its DHCP range to leave you a "gap" of addresses. DHCP devices get a range of xxx.12 to xxx.100 on my network.

You can then configure your computer to have a static IP in the range .2-.11 (given that .1 is probably the router itself), or .101-.254. You now have ample room for expansion of both the DHCP and non DHCP devices. This is pretty much exactly the set up I have. This means that the NAT is still translating.

Thanks Luca for linking those bugs in.
Danny

peter b (b1pete) said : #19

hello to all!

finally a bit of good news, somewhere somone heard my/our problems.

the other day I downloaded and tried the newly minted EDGY distro amd64 of Ubuntu; it worked - the router/nat was seen by the live CD and could connect to the net with ease.

However, (does this however or but must always have to be there??) it appears the dhcp problems were solved but ... another one raise its ugly head namely the PC freezes after issueing the Quit command; the user is prompted to remove the CD, close the tray and press Enter, all is good and happy until Enter is pressed when the Ubuntu logo and the progress bar sits on the screen for ever. the only keys available are the combo Ctrl-Alt-Del that triggers another tray open-close sequence and .... you get the idea.

on the following days I'll try Kubuntu Edgy to see how it delivers.

Cheers to all, esp Danny and Luca for helping bring a resolution to the dhcp situation in Dapper.

Can you help with this problem?

Provide an answer of your own, or ask Martin Thomas for more information if necessary.

To post a message you must log in.