How to access postgresql servers > 9.5?

Asked by Marc F. Neininger on 2018-02-14

Hi,
i'm using 16.04 xenial as host for applications. Our DB-server was updated from 9.4 to 9.6 recently and I'm using pg_dump from time to time to clone databases. But I'm no more able to do that :-(

Right now postgresql-client-common can connect to pg up to version 9.5 . I tried to install postgresql-client-9.6 manually but I failed because postgresql-client-9.6 depends on a newer version of libpg5. As a workaround I tried to manually install the latest version of libpg5 (9.6.7) but another depenency (libgss...?) failed.
Can you please have a look or even ask upstream about the possibility to provide postgresql-client for all current server versions (9.6,and 10.2??)

Nevertheless thank you all for providing the software. It works like a charm

Marc

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu postgresql-common Edit question
Assignee:
No assignee Edit question
Solved by:
Marc F. Neininger
Solved:
2018-02-14
Last query:
2018-02-14
Last reply:
2018-02-14

https://launchpad.net/ubuntu/+ppas?name_filter=postgresql-common

You may find a PPA with the version you desire. Remember to filter the PPA for Xenial so you know it has the application for your release.

You could report a bug. If the bug and security fixes are significant then the package may be updated in the official repositories sooner rather than later.

Hi Andrew,
thanks for your answer. I'm using postgresql in a commercial environment. My server is even behind a firewall in a DMZ with no access than to our own ubuntu-mirror.
For personal use I would also install from different sources, but in the professional environment I'm obliged to minimize risks and therefore it is strictly forbidden to install untrusted software. We are handling a mass of personal data that has to be stored in a secure way. And - sorry for my doubts - a chain is always as strong as its weakest chain link. Therefore I don't want to, and it is even forbidden, to weaken the system.

Is there any chance that some of the untrusted software might find its way into the official release? I think that the LTS system should provide actual client software for state of the art, not even bleeding edge, server software...

Best regards and thanks for your answer

Marc

No untrusted software is in the official repositories. They are all built by Canonical by the Ubuntu packaging team.

The only way I can suggest that the package is updated is via a bug report

Bionic (Ubuntu 18.04 LTS) may have a newer version but is not due for release until April 2018

Hi Andrew,

I tried to file a bug against postgresql-client-common but I didn't succeed :-/
The webinterface tells me that "no similar bug reports were found".

Artful aardvark provides pg 9.6... and postgresql-client-9.6 . But the dependencies are rather challenging. As mentioned above I tried to update via .deb-file but for the 9.6 client package some libs also need to be updated inside 16.04 .

@all: can anybody please transform my question into a bug?
That would be great

Thanks in advance

Marc

Manfred Hampl (m-hampl) said : #5

Try the "Create bug report" link in your question document (just above the "Message:" box).

Hi Andrew and Manfred,

thanks for the help. I created the bug report now. From time to time it might be good to read the whole web form.

Thanks

Marc
P.S.: I hope it will work.