versions problem client server

Asked by Marc F. Neininger on 2017-10-06

Hallo,
ich nutze Xenial auf einem Server und spreche mit einem dedizierten DB-Server. Der DB-Server ist aktuell auf Version 9.4.8, ich habe Xenial und nur ein lokales Repository, in dem ich postgresql-client 9.5 habe. Beim Dump und Restore habe ich jetzt Probleme mit der row-security, die wohl in den Clienten ausgewertet wird, die die DB aber noch garnicht kennt.

Wäre es möglich, neben einer stabilen Postgresql-Server version (gerne auch der 9.5) mehrere Versionen von Client-Libs anzubieten, damit man auch mit anderen PG-Servern ohne Versionsprobleme sprechen kann?
Also direkt im Repo auch noch die postgresql-client-9.4 zu haben?

Danke und auch Danke für das Pflegen

Marc
== Text in english ====

I'm working in the field of application administration. Therefore I have a server with Xenial and no uplink to the internet. The connected database server (not my one) is pg with version 9.4.8. With xenial I do have only postgresql-client 9.5. When dumping and restoring the 9.4.8 with client version 9.5 I run into trouble as the restore asks me about row_security. No matter if I turn row_security in the restore on or off the action aborts with mentioning that the attribute "row_security" is unknown...

If possible I would ask you to add postgresql-client in older or even newer versions to the official xenial repository to avoid version conflicts. IMHO it would be a benefit if the users were not only able to install the current but also other versions as these packages should fit to db-servers with different versions.

Best regards

Marc

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu postgresql-common Edit question
Assignee:
No assignee Edit question
Last query:
2017-10-06
Last reply:
15 hours ago
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.