Ubuntu

Install wildspeed on postgresql 8.4, ubuntu 10.04 LTS

Asked by Marc Hauswirth on 2011-10-18

Hello,
I spend some time to try to install wildspeed (contrib module).

taking the sources from http://www.sigaev.ru/cvsweb/cvsweb.cgi/wildspeed/#dirlist
(some minor changes since http://www.sai.msu.su/~megera/wiki/wildspeed)

Needed aditional package : postgresql-server-dev-8.4

I had to modify a bit the Makefile to force the use of pgxs

PG_CPPFLAGS = -DOPTIMIZE_WILDCARD_QUERY
MODULE_big = wildspeed
OBJS = wildspeed.o

DATA_built = wildspeed.sql
DATA = uninstall_wildspeed.sql
REGRESS = wildspeed

PG_CONFIG = pg_config
PGXS := $(shell $(PG_CONFIG) --pgxs)
include $(PGXS)

then the installation procedure :
  make
  make install
  psql regression < wildspeed.sql (I used my favorite PG SQL browser to do this part...)

Now it's work ;-)

Hope this will help someone else ...

Regards,

Marc

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu postgresql-8.4 Edit question
Assignee:
No assignee Edit question
Solved by:
Marc Hauswirth
Solved:
2011-10-18
Last query:
2011-10-18
Last reply:
Marc Hauswirth (marc-practeo) said : #1

Answer in the question ;-)
My sources are :
http://open.practeo.ch/postgres/wildspeed.tar.gz

regards,
Marc

DaFloydDoc (glagues) said : #2

Thanks a lot for this help
I had only a few hair left while trying to compile this.
Now it's works and I am testing it.