cannot find the file libexpat.so.0

Asked by nrei on 2008-09-18

I'm new to Linux. I'm running Ubuntu 8.04.1 LTS Desktop Edition. I am trying to install PostgreSQL on my system. I downloaded the one click installer and ran it. It seemed to work. But when I double click on the pgadmin3 icon, nothing happens. So I tried running it on the command line. I got an error message saying it couldn't find the file libexpat.so.0. There is no such file on my system. There is, however, libexpat.so.1. I tried reloading the libexpat1 package, but it appears it no longer contains this file.

How can I find a copy of libexpat.so.0? Is there some web site I can download it from? Is it hiding in some package I don't know about?

Thanks for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu postgresql-8.3 Edit question
Assignee:
No assignee Edit question
Solved by:
nrei
Solved:
2008-09-18
Last query:
2008-09-18
Last reply:
2008-09-18
Daniel Schwitzgebel (schwitzd) said : #1

try to install the packages ia32-libs

nrei (nrei25) said : #2

I tried:

sudo apt-get install ia32-libs

and got back

Couldn't find package ia32-libs

a little poking around via google, and I learned ia32-libs is supposedly only for 64-bit systems. I'm running in 32bits.

Any other ideas?

nrei (nrei25) said : #3

I found the answer at

Bug #218963: libexpat1 does not contain libexpat.so.0 in 8.04 Beta
https://bugs.launchpad.net/ubuntu/+source/expat/+bug/218963

Somehow I missed this when searching launchpad the first time.

libexpat.so.0 has indeed been eliminated from unbuntu 8.04

the command suggested in the above post does indeed work.

sudo ln -s /usr/lib/libexpat.so.1 /usr/lib/libexpat.so.0

I'm up and running now.

nrei (nrei25) said : #4