postfix won't start, but doesn't write any errors

Asked by Sebastian Mares on 2017-11-13

I have updated from Ubuntu 17.04 to Ubuntu 17.10 and postfix won't start.

"systemctl start postfix" doesn't print anything.

"/etc/init.d/postfix start" prints "[ ok ] Starting postfix (via systemctl): postfix.service." but postfix isn't running.

"systemctl status postfix" prints:

● postfix.service - Postfix Mail Transport Agent
   Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2017-11-14 00:41:01 CET; 3min 13s ago
  Process: 1556 ExecReload=/bin/true (code=exited, status=0/SUCCESS)
  Process: 449 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 449 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/postfix.service

The /var/log/mail.log and /var/log/mail.err files don't contain anything related to postfix, only dovecot.

Any idea what I can do to debug?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu postfix Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-14
Last reply:
2017-11-14

Can you Telnet to port 25? This will mean the service is running

Sebastian Mares (smares) said : #2

No, 25 and 587 are both unreachable. Something that netstat also confirms. I don't see any postfix related process in ps either.

One very weird thing is that I checked the postfix override file in /etc/systemd/system/postfix.service.d (IIRC) and renamed to it override.conf.bak, did a systemctl daemon-reload and then started postfix. It worked. Rebooted the server, no postfix. Attempted to start it manually, nothing. Renamed the override.conf.bak back to override.conf, did a systemctl daemon-reload, started postfix, worked again. Rebooted the server, didn't work any longer.

Sebastian Mares (smares) said : #3

And just to avoid such a question, postfix is the only mail server installed, no exim whatsoever that butt in. :)

Are there any bugs reported? Seems weird that you aren't running the latest LTS release (Ubuntu 16.04) on such a server

Can you help with this problem?

Provide an answer of your own, or ask Sebastian Mares for more information if necessary.

To post a message you must log in.