libsasl2-2 conflicts with postfix

Asked by anakbawang on 2007-07-28

I can not install libsasl2-2 due to conflicts with postfix.
and I already try to install both package from debian and ubuntu (libsasl2-2_2.1.22.dfsg1-8ubuntu2_i386.deb) but in result with same error message attached below

dpkg: regarding libsasl2-2_2.1.22.dfsg1-13_i386.deb containing libsasl2-2:
 libsasl2-2 conflicts with postfix (<< 2.3.4-3)
  postfix (version 2.2.10-1ubuntu0.1) is installed.
dpkg: error processing libsasl2-2_2.1.22.dfsg1-13_i386.deb (--install):
 conflicting packages - not installing libsasl2-2
Errors were encountered while processing:
 libsasl2-2_2.1.22.dfsg1-13_i386.deb

Do you have solution for above problem?

Thanks,
AR

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu postfix Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Michael Bienia (geser) said :
#1

Which version of Ubuntu are you using?

libsasl2-2 2.1.22.dfsg1-8ubuntu2 is from feisty but postfix 2.2.10-1ubuntu0.1 is from dapper.

Mixing packages from different Ubuntu releases (or Debian) doesn't always work and is not supported.

If you are using dapper use libsasl2 2.1.19.dfsg1-0.1ubuntu2 or if you are using feisty use postfix 2.3.8-2.

Revision history for this message
Launchpad Janitor (janitor) said :
#2

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Revision history for this message
anakbawang (ruhanda) said :
#3

I'm using Ubuntu 6.06 server LTS

Revision history for this message
Michael Bienia (geser) said :
#4

Downgrading libsasl2 to 2.1.19.dfsg1-0.1ubuntu2 (the version from Ubuntu 6.06) should fix your dependency problem for postfix.

May I ask you why you try to install a package which is not for the Ubuntu release you use?

Can you help with this problem?

Provide an answer of your own, or ask anakbawang for more information if necessary.

To post a message you must log in.