unable to locate packages when tried with apt-get install

Asked by Sally on 2016-06-06

my computer version is Ubuntu 16.04,xenial,
what I 'm trying to get is libPocoFundation.so.21 since I received the error message: error while loading shared libraries: libPocoFoundation.so.21: cannot open shared object file: No such file or directory.
so i tried to install libPocoFoundation.so.21.
I tried get apt install update and upgrade.
still not working.
I can't find the package when I tried what described here in http://askubuntu.com/questions/378558/unable-to-locate-package-while-trying-to-install-packages-by-apt
but still not working. when it comes to add ppa, I don't know how to do it.
Hope anyone can give some hints.
this problem puzzled me for almost two weeks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu poco Edit question
Assignee:
No assignee Edit question
Last query:
2016-06-06
Last reply:
2016-06-06

Linux is extremely case sensitive. You cant just add capital letters because you feel like it

Manfred Hampl (m-hampl) said : #2

What program are you running to get that error message?
Is this a program that you installed from the Ubuntu repositories, or from some foreign source?

The Ubuntu poco packages provide only /usr/lib/libPocoFoundation.so.9

Maybe this packages need a version of poco higher than the one in the standard Ubuntu repositories.
If that is the case, you could perhaps try the PPA https://launchpad.net/~zosrothko/+archive/ubuntu/poco

Manfred Hampl (m-hampl) said : #3

Sorry, that PPA will not work, because it provides a too high version - libPocoFundation.so.43

Sally (gengyayuan) said : #4

@ actionparsnip (andrew-woodhead666) , thanks for your nice reply. But I didn't get you very much.
would you please tell in more details?
appreciated.

Don't put capital letters in package names, commands or file names unless you know they have capital letters in them.

 libPocoFoundation.so.21 is not the same as libpocofoundation.so.21

Can you help with this problem?

Provide an answer of your own, or ask Sally for more information if necessary.

To post a message you must log in.